Bug 116389 - SMP kernel won't boot on A31p Thinkpad (required for oprofile)
SMP kernel won't boot on A31p Thinkpad (required for oprofile)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Paradis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 12:43 EST by Anthony Green
Modified: 2013-08-05 21:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 11:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from /usr/bin/dmidecode (12.65 KB, text/plain)
2004-03-01 13:13 EST, Anthony Green
no flags Details
/sbin/dmidecode from tburke's A31p (12.91 KB, text/plain)
2004-03-01 15:18 EST, Jim Paradis
no flags Details

  None (edit)
Description Anthony Green 2004-02-20 12:43:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Apparently the oprofile tool will only work with the SMP kernel.
This kernel fails to boot on my A31p ThinkPad.
It spits out some messages, and then simply freezes.  The last message
has something to do with hugemem.

If there's some other way to get oprofile working, please let me know.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-9.EL

How reproducible:
Always

Steps to Reproduce:
1.up2date SMP kernel on A31p ThinkPad
2.Boot

    

Additional info:
Comment 1 Tim Burke 2004-02-26 17:37:30 EST
I've been running the smp kernel on my A31p system for a long time now....


Hmmm, wonder if something broke in the newer kernel?

[tburke@tim tburke]$ uname -a
Linux tim.boston.redhat.com 2.4.21-5.ELsmp #1 SMP Mon Dec 1 17:20:05
EST 2003 i686 i686 i386 GNU/Linux
Comment 3 Anthony Green 2004-02-26 17:59:09 EST
I see there's an even newer kernel now (2.4.21-9.0.1.EL).  I'll try
that as well.

BTW, I write "hugemem" above, but I meant "HugeTLB".

Comment 4 Anthony Green 2004-03-01 12:40:40 EST
I tried the latest kernel (2.4.21-9.0.1.ELsmp) and have the same problem.

tburke claims that 2.4.21-5.ELsmp worked on the A31p.  How do I get my
hands on that?

Thanks!
Comment 5 Jim Paradis 2004-03-01 13:10:43 EST
Can you run /sbin/dmidecode and attach the output?  I'm suspecting a
BIOS issue...
Comment 6 Anthony Green 2004-03-01 13:13:57 EST
Created attachment 98166 [details]
Output from /usr/bin/dmidecode
Comment 7 Jim Paradis 2004-03-01 15:18:38 EST
Created attachment 98171 [details]
/sbin/dmidecode from tburke's A31p

I got the attached /sbin/dmidecode output from tburke.	Diffing the two, I
notice two major differences: different BIOS rev (1.03 on the failing system,
1.02 on tburke's system) and different mainboard model numbers.  This suggests
to me that any comparison between the failing system and tburke's
successfully-booting system may not be 100% meaningful.
Comment 9 Jim Paradis 2004-04-07 19:07:37 EDT
Anthony - any updates on this issue?
Comment 10 Anthony Green 2004-04-07 19:18:29 EDT
Thanks for the ping.  I didn't notice your update on 2004-03-01!

I've since had the mainboard replaced on my laptop (video failed, so
IBM swapped out the whole mainboard), and I haven't tried since.  I'll
try now.

Thanks,

AG
Comment 11 Jim Paradis 2004-07-06 16:30:03 EDT
Anthony - have you had a chance to try this?

--jim
Comment 12 Jim Paradis 2004-11-18 11:11:15 EST
No news is good news; I presume it's working fine for you.  Closing this as
CURRENTRELEASE under the assumption that the current release works on this hardware.

Note You need to log in before you can comment on or make changes to this bug.