Bug 116391 - useradd: cannot rewrite shadow password file
useradd: cannot rewrite shadow password file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: passwd (Show other bugs)
2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-20 12:59 EST by Sean Neeley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 15:10:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Neeley 2004-02-20 12:59:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I just installed a fresh copy of Fedora Core 2 from the development
directory.  After the first reboot, I tried to add a user as follows:

useradd sen

Then received the following error message:

useradd: cannot rewrite shadow password file

If I manually add the user to /etc/passwd, when I try to assign a
password to the user, the passwd command hangs.

After the _second_ boot, I saw the X windows screen from the firstboot
program telling me to set up a non-root account.  When I tried to add
the user 'dbc' this time, I received an error.  Here is the contents
of the firstboot error log:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 269, in
nextClicked 
    result = module.apply(self.notebook)
  File "/usr/share/firstboot/modules/create_user.py", line 225, in apply 
    self.admin.modifyGroup(groupEnt)
RuntimeError: data not found in file


Version-Release number of selected component (if applicable):
pam-0.77-33, kernel-2.6.2-1.87

How reproducible:
Always

Steps to Reproduce:
1. Install fresh Fedora Core 2 test1
2. Try 'useradd' command
3.
    

Additional info:
Comment 1 Daniel Walsh 2004-03-25 15:18:25 EST
Updates selinux policy to 1.9-15.  Is this problem fixed?

Dan
Comment 2 Sean Neeley 2004-03-25 15:31:04 EST
I'm sorry but I cannot test this for you.  I reported this bug over a
month ago, and I could only go a few days without being able to add
users to my system.  I replaced my install of Fedora Core 2 with SuSE 9.
Comment 3 John R 2004-03-30 10:59:45 EST
I just installed fedora core 2 test 2, and this problem exists.  The
system has policy-1.9-15 and policycoreutils-1.9-12.
Comment 4 John R 2004-03-30 13:15:59 EST
Hmmm... nevermind.  I installed the policy source, ran make relabel on
the filesystems, and everything was fine.  I ran the installation
again to check the problem, formatting the drives as before, but the
problems didn't manifest.  It must have been a hiccup during the first
installation.
Comment 5 Daniel Walsh 2004-03-30 15:10:54 EST
You should only see this if the /etc/shadow or /etc/passwd file got
mislabled.

So if somehow they are getting mislabled we have a problem.  Make
relabel or restorecon /etc/shadow /etc/passwd would clear it up.

Dan

Note You need to log in before you can comment on or make changes to this bug.