Bug 1163978 - Setting start page as Clouds/Availability Zones shows "Page doesnt exist"
Summary: Setting start page as Clouds/Availability Zones shows "Page doesnt exist"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.3.0
Hardware: All
OS: All
low
high
Target Milestone: GA
: 5.4.0
Assignee: Josh Carter
QA Contact: Nandini Chandra
URL:
Whiteboard:
Depends On:
Blocks: 1166286
TreeView+ depends on / blocked
 
Reported: 2014-11-13 20:39 UTC by Josh Carter
Modified: 2018-12-09 19:10 UTC (History)
4 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, if a user's start page was set to 'Clouds/Availability Zones', on logging in the user was presented with 'a page does not exist' error. This was because there was no link to the 'Cloud/Availability Zones' page in the start page code. This bug was fixed by adding the missing link to 'Clouds/Availability Zones' in the start page. There are no errors in presenting the start page in the new version of CloudForms Management Engine.
Clone Of:
: 1166286 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:44:35 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Josh Carter 2014-11-13 20:39:16 UTC
Description of problem:

If a user sets their start page for "Clouds/Availability Zones" the next time the user logs in they will be presented with "The page you were looking for doesn't exist" 

It does not matter if the CFME has a cloud env added to it or not. I also verified this on master	master.20141113152047_435f8bd  


Version-Release number of selected component (if applicable): 5.3.0


How reproducible:
very 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 CFME Bot 2014-11-13 23:35:48 UTC
New commit detected on cfme/master:
https://github.com/ManageIQ/manageiq/commit/fe51a7f7c94c51494105bbc40e8b69dba86bf6cb

commit fe51a7f7c94c51494105bbc40e8b69dba86bf6cb
Author:     Josh Carter <jocarter@redhat.com>
AuthorDate: Thu Nov 13 15:58:05 2014 -0500
Commit:     Josh Carter <jocarter@redhat.com>
CommitDate: Thu Nov 13 15:58:05 2014 -0500

    Fixed the linking for user start page to availability zones.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1163978

 vmdb/db/fixtures/miq_shortcuts.yml | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 6 CFME Bot 2014-11-13 23:36:14 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/fe51a7f7c94c51494105bbc40e8b69dba86bf6cb

commit fe51a7f7c94c51494105bbc40e8b69dba86bf6cb
Author:     Josh Carter <jocarter@redhat.com>
AuthorDate: Thu Nov 13 15:58:05 2014 -0500
Commit:     Josh Carter <jocarter@redhat.com>
CommitDate: Thu Nov 13 15:58:05 2014 -0500

    Fixed the linking for user start page to availability zones.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1163978

 vmdb/db/fixtures/miq_shortcuts.yml | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 8 Nandini Chandra 2015-02-18 05:06:25 UTC
Verified in master.20150129190745_56f255b

Comment 11 errata-xmlrpc 2015-06-16 12:44:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.