Bug 1164050 - filespec_add: conflicting specifications for /opt/VBoxGuestAdditions-4.3.18/lib/VBoxGuestAdditions/98vboxadd-xclient and /opt/VBoxGuestAdditions-4.3.18/bin/VBoxClient-all, using system_u:object_r:bin_t:s0.
Summary: filespec_add: conflicting specifications for /opt/VBoxGuestAdditions-4.3.18/...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-14 01:21 UTC by Andre Robatino
Modified: 2014-11-22 21:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 11:45:24 UTC


Attachments (Terms of Use)
Rawhide screenshot while doing an SELinux relabel (20.49 KB, image/png)
2014-11-14 01:21 UTC, Andre Robatino
no flags Details

Description Andre Robatino 2014-11-14 01:21:53 UTC
Created attachment 957380 [details]
Rawhide screenshot while doing an SELinux relabel

Description of problem:
In both my F21 and Rawhide VirtualBox guests, with guest additions installed, if I do an SELinux relabel, I get the error message in the Summary. I know virtually nothing about SELinux so don't know the significance, but mjg59 on #fedora-devel thought it was probably not a VirtualBox bug. I don't have a F20 VirtualBox guest so don't know if it happens there.

<robatino> is the selinux error in https://forums.virtualbox.org/viewtopic.php?f=1&t=64104&start=30#p303681 definitely a virtualbox bug? (not sure, haven't gotten a response there)
<mjg59> robatino: Unless they're providing their own selinux policy, I can't see any obvious way for it to be a virtualbox bug

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-92.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. Do an SELinux relabel

Comment 1 Lukas Vrabec 2014-11-14 12:54:28 UTC
Do you have some policy which we don't ship in selinux-policy package?

Comment 2 Andre Robatino 2014-11-14 15:39:50 UTC
As I said, I know virtually nothing about SELinux, so I wouldn't be capable of creating a policy, even if I knew what it was. Is this something that the VirtualBox package could impose on its own, without my knowledge, and if so, how do I find out?

Comment 3 Andre Robatino 2014-11-14 16:17:27 UTC
Just to add, when I install the VirtualBox guest additions, I'm running a VirtualBox-provided shell script, so it could do anything. It sounds like it's probably their bug, but what should I look for in order to give them a proper bug report?

Comment 4 Lukas Vrabec 2014-11-19 11:45:24 UTC
Try to report it somewhere on VirtualBox BZ.

I close this. If guys from VirtualBox detect that this is selinux bug, please re-open this.

Comment 5 Andre Robatino 2014-11-22 21:55:45 UTC
https://www.virtualbox.org/ticket/13627 (for anyone else who comes across this). It is their bug and looks like it should be fixed in their next release.


Note You need to log in before you can comment on or make changes to this bug.