Bug 1164059 - CryptoError: luks_format failed for '/dev/sda3'
Summary: CryptoError: luks_format failed for '/dev/sda3'
Keywords:
Status: CLOSED DUPLICATE of bug 1160289
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bce11a9ae76b874b584c0193062...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-14 02:45 UTC by Paul Whalen
Modified: 2014-11-14 02:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-14 02:52:34 UTC


Attachments (Terms of Use)
File: anaconda-tb (391.50 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: anaconda.log (20.50 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: environ (459 bytes, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: lsblk_output (1.26 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: nmcli_dev_list (983 bytes, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: os_info (377 bytes, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: program.log (30.06 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: storage.log (167.29 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: syslog (38.65 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: ifcfg.log (1.39 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details
File: packaging.log (86.49 KB, text/plain)
2014-11-14 02:45 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2014-11-14 02:45:01 UTC
Description of problem:
Installation of F21 Beta RC1, automatic partitioning with encryption. 

Version-Release number of selected component:
anaconda-21.48.13-1

The following was filed automatically by anaconda:
anaconda 21.48.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/crypto.py", line 103, in luks_format
    raise CryptoError("luks_format failed for '%s'" % device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 239, in create
    min_entropy=self.min_luks_entropy)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 560, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 361, in processActions
    action.execute(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 364, in doIt
    self.devicetree.processActions(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 190, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
CryptoError: luks_format failed for '/dev/sda3'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/fedora/aarch64/21_Beta_RC1/vmlinuz inst.repo=http://rhel/fedora/fedora-release/aarch64/21_Beta_RC1/ ro console=ttyS0,115200n8
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.2-300.fc21.aarch64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Paul Whalen 2014-11-14 02:45:03 UTC
Created attachment 957389 [details]
File: anaconda-tb

Comment 2 Paul Whalen 2014-11-14 02:45:05 UTC
Created attachment 957390 [details]
File: anaconda.log

Comment 3 Paul Whalen 2014-11-14 02:45:05 UTC
Created attachment 957391 [details]
File: environ

Comment 4 Paul Whalen 2014-11-14 02:45:06 UTC
Created attachment 957392 [details]
File: lsblk_output

Comment 5 Paul Whalen 2014-11-14 02:45:07 UTC
Created attachment 957393 [details]
File: nmcli_dev_list

Comment 6 Paul Whalen 2014-11-14 02:45:08 UTC
Created attachment 957394 [details]
File: os_info

Comment 7 Paul Whalen 2014-11-14 02:45:09 UTC
Created attachment 957395 [details]
File: program.log

Comment 8 Paul Whalen 2014-11-14 02:45:10 UTC
Created attachment 957396 [details]
File: storage.log

Comment 9 Paul Whalen 2014-11-14 02:45:11 UTC
Created attachment 957397 [details]
File: syslog

Comment 10 Paul Whalen 2014-11-14 02:45:12 UTC
Created attachment 957398 [details]
File: ifcfg.log

Comment 11 Paul Whalen 2014-11-14 02:45:13 UTC
Created attachment 957399 [details]
File: packaging.log

Comment 12 Paul Whalen 2014-11-14 02:52:34 UTC

*** This bug has been marked as a duplicate of bug 1160289 ***


Note You need to log in before you can comment on or make changes to this bug.