Bug 116406 - Error Getting SPEC2000 to compile
Error Getting SPEC2000 to compile
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 14:55 EST by Brock Organ
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 17:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text of compile session (99.67 KB, text/plain)
2004-02-20 14:56 EST, Brock Organ
no flags Details

  None (edit)
Description Brock Organ 2004-02-20 14:55:34 EST
* reported by customer
* RHEL3-U1 on s390

From customer:

"We can't get spec to compile. This worked previously on EL3, but we
now have update 1 and it does not seem to work. Is there something we
need to do that is obvious?"

See attachment for listing of spec compile session ...
Comment 1 Brock Organ 2004-02-20 14:56:15 EST
Created attachment 97881 [details]
text of compile session
Comment 2 Vladimir Makarov 2004-02-26 16:56:52 EST
  I was able to reproduce the bug only on s390 under RHEL3 udpate 1. 
It looks like Berkley DB has version 2 when SPEC2000 was written. 
This version contained definition of DB_INFO (in file db.h).  RHEL3
uses DB version 4.  DB_INFO was removed since DB version 3.

  SPEC2000 contains obsolete code (in file
toosl/src/perl5.005_03/ext/DB_File/DB_FIle.xs)
#ifdef DB_MAJOR_VERSION
...
typedef DB_INFO INFO;
#endif

It should be
#if DB_MAJOR_VERSION==2
...
#endif

   The reason why other platforms (I've tried x86_64) has no such
problem is in that perl5.005_03/Configure can not find a Berkley db
library (it searches for db.a liddb.a libdb.so libdb_s.a in /lib
/usr/lib /usr/local/lib) therefore the symbol db_version is unresolved
by linker and Configure script switches off usage of Berkley DB.

   On s390 under RHEL3 (update 1) the script finds libdb.so in
/usr/lib.  RHEL3 without update has only libdb-4.1.so.  It can not be
found by the SPEC perl script.  If it succeeded, RHEL3 without update
had the same problem.

 So the real problem is in the SPEC2000 obsolete code.  To fix the
problem you should use the correct code mentioned above.

Best regrads,
Vladimir Makarov,
Gcc engineer

Comment 3 Mike Reeves 2004-06-17 10:17:13 EDT
I have notified the programmer who compiles and runs the SPEC2000 
with this update.

thx MR
Comment 4 Richard Henderson 2004-10-04 17:13:46 EDT
So closing as not a tools bug.

Note You need to log in before you can comment on or make changes to this bug.