Bug 116410 - syslogd and klogd segfaults on clean system
syslogd and klogd segfaults on clean system
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-20 15:33 EST by Per-Stian Vatne
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 15:02:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Misc logs from strace (13.47 KB, application/octet-stream)
2004-02-21 08:34 EST, Per-Stian Vatne
no flags Details

  None (edit)
Description Per-Stian Vatne 2004-02-20 15:33:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Fresh install of Fedora Core from Devel Tree (x86_64), boot image used
from 19.02.2004. Cannot get syslog service starting, fails and
segfaults. A bit difficult to find useful debug data as nothing is
logged. 

[root@localhost root]# service syslog start
Starting system logger:                                    [FAILED]
Starting kernel logger:                                    [FAILED]
[root@localhost root]# syslogd -v
Segmentation fault
[root@localhost root]# klogd -v
Segmentation fault


Version-Release number of selected component (if applicable):
sysklogd-1.4.1-13.1

How reproducible:
Always

Steps to Reproduce:
1. Start system...
2. Service won't start
3.
    

Actual Results:  Service unable to start, seg faulting, 

Expected Results:  syslog starting...

Additional info:

Linux localhost.localdomain 2.6.3-1.91 #1 Wed Feb 18 23:09:43 EST 2004
x86_64 x86_64 x86_64 GNU/Linux

Running on SATA disks with software raid and lvm on top, sata_promise
driver.

selinux=0 in boot option (same error without this option, though)
Comment 1 Bill Nottingham 2004-02-20 23:44:28 EST
Odd. What does an strace show?
Comment 2 Per-Stian Vatne 2004-02-21 08:34:51 EST
Created attachment 97906 [details]
Misc logs from strace

See attachments. Compared to a working system on same level (i386, though), the
strace log ends at the init of fstat64. There are more services segfaulting in
the same way - like httpd, smbd and crond. Some services like mysqld and sshd,
work fine though.

Lots of stuff seg faulting, so something form another component (kernel?)
maybe. 

Normally would be lots of stuff I could've messed up by playing around, but
this is a clean and fresh install on all new hardware.
Comment 3 Per-Stian Vatne 2004-02-21 09:17:59 EST
Just a quick note, I ran memtest86+ to make sure my new hardware
wasn't faulty. No problems found.
Comment 4 Per-Stian Vatne 2004-02-21 11:59:53 EST
Started playing around a little bit as there was released a more
recent kernel (kernel-2.6.3-1.96). However, this kernel did not
recognize my logical volume and failed at boot asking for e2fsck.ext3
and fixing (and so on). Booting with kernel-2.6.3-1.91 again brings up
the system, but with the errors mentioned in this bug report.

As I suspected the kernel to have problems, I found the previous
version , kernel-2.6.2-1.87, and was surprised to see everything work
with this version, lvm and everything. So for... 

Linux localhost.localdomain 2.6.2-1.87 #1 Mon Feb 16 18:54:49 EST 2004
x86_64 x86_64 x86_64 GNU/Linux

...the problems mentioned in this report are non-existent. For the
2.6.3 kernels I've tried (only from devel, not recompiled) the -91 seg
faults a lot, and -96 won't boot on my file system.

So I guess this bug should be moved away from sysklogd and the kernel?
I'm not sure how to do that, but I'm sure someone else knows. Thanks.
Comment 5 Per-Stian Vatne 2004-02-27 15:02:40 EST
Problem with filesystem/lvm is not solved by upgrading kernels (-97,
-100, -106, -109, -110), but still works with -87 (2.6.2). With the
-91 kernel it also works for the filesystem, but all the seg faulting.
So cannot tell if it solves the actual problem.

I've noticed someone else logged a bug for the filesystem/lvm problem,
see bug number 116573, this is the exact same error - but not the one
the bug was originally logged for.

Yesterday I formatted and reinstalled the system from devel tree using
-106 kernel (25/2-2003), all same settings, and everything is just
fine. Also, after upgrades to -109 and -110 still works just fine.

So bug sort of solved I guess, closed it as "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.