Bug 116412 - hwclock hangs during install
hwclock hangs during install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 15:50 EST by Adam Thompson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 16:37:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Thompson 2004-02-20 15:50:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
During install, no matter whether text mode or graphical, interactive 
or kickstart, at the "setuptime" stage, hwclock runs and... hangs.
Killing hwclock from tty1 allows the installation to proceed.

Occurs on CD boot, PXE boot, local install and net install.



Version-Release number of selected component (if applicable):
FC1

How reproducible:
Always

Steps to Reproduce:
1. Install FC1
2. Wait forever :-)
3.
    

Actual Results:  Installer waits forever for hwclock to return
(hwclock --systohc -w)


Expected Results:  clock should be set and install should proceed

Additional info:

Motherboard: ASUS CUV4X
Comment 1 Jeremy Katz 2004-02-22 22:29:43 EST
Either an hwclock or a kernel bug...
Comment 2 Elliot Lee 2004-08-31 18:29:22 EDT
Since the kernel has changed to a new major version since this report,
I think it would be worthwhile to try FC2 on the system and see if
that works.

It sounds hardware-dependant, so I don't know how helpful I can be in
debugging the problem. If you can attach gdb to hwclock and find out
what it's up to, we can work together on tracking down the cause of
the problem.
Comment 3 Adam Thompson 2004-08-31 22:32:13 EDT
1) it's definitely hardware dependant, as other Linux users (not just
RH or FC) have reported similar problems on other ASUS motherboards
from the same generation and chipset.

2) I am scheduled to install FC2 on one of the affected systems in the
near future already.

3) The simple workaround:   --directisa
   (which implies the bug lives in the kernel's RTC driver, maybe?)
Comment 4 Adam Thompson 2004-09-24 16:37:09 EDT
FC2 works fine.  Grepping usenet indicates most people with this
generation of ASUS motherboard are experiencing the same thing - 2.6
fixes it.

Note You need to log in before you can comment on or make changes to this bug.