Bug 1164195 - Anaconda allows autopart installation of /boot to iSCSI disc
Summary: Anaconda allows autopart installation of /boot to iSCSI disc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Samantha N. Bueno
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1112660 1189279 1273316 1623849
TreeView+ depends on / blocked
 
Reported: 2014-11-14 10:09 UTC by Pavel Holica
Modified: 2018-08-30 10:18 UTC (History)
7 users (show)

Fixed In Version: anaconda-21.48.22.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1273316 (view as bug list)
Environment:
Last Closed: 2015-11-19 09:48:03 UTC


Attachments (Terms of Use)
anaconda.log (16.57 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
ifcfg.log (4.29 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
packaging.log (772.44 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
program.log (135.65 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
storage.log (268.09 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
storage.state (32.00 KB, application/octet-stream)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
syslog (82.93 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details
X.log (15.00 KB, text/plain)
2014-11-14 15:23 UTC, Pavel Holica
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2284 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-11-19 09:44:49 UTC
Red Hat Bugzilla 1269195 None None None Never
Red Hat Bugzilla 1294571 None None None Never

Internal Links: 1269195 1294571

Description Pavel Holica 2014-11-14 10:09:37 UTC
Description of problem:
I've had previous installation of RHEL-7 on local HDD (autopart) and when reinstalling system, I've added iSCSI target. After adding target, I left "Automatically configure partitioning" selected. Anaconda then used local HDD for bootloader and put /boot and / on iSCSI target without any warning. Such setup end in grub rescue unable to find device with /boot.

Version-Release number of selected component (if applicable):
RHEL-7.1-20141029.0 x86_64 Client
anaconda-19.31.104-1.el7

How reproducible:
always

Steps to Reproduce:
1. Install RHEL-7 (or any other) on local HDD using all space available
2. Start another installation
3. Add iSCSI target
4. Use default partitioning
5. Complete installation

Actual results:
anaconda uses local HDD as bootloader location
anaconda puts /boot and / on iSCSI target
grub cannot user /boot located on iSCSI target

Expected results:
Anaconda warns about wrong partitioning or doesn't allow such partitioning when iSCSI is connected manually and shows reclaim dialog.

Additional info:
Such setup is ok with iBFT setup but not with iSCSI connected manually in anaconda.

Comment 1 Martin Kolman 2014-11-14 11:28:10 UTC
Could this be a manifestation of bug 1161644 (iSCSI disk showing as local devices due to borked udev) ?

Comment 2 Pavel Holica 2014-11-14 11:37:15 UTC
I'm not sure, but I saw the iSCSI disk in specialized section all the time.

Comment 3 Samantha N. Bueno 2014-11-14 14:19:25 UTC
Could you attach logs, Pavel? You should be able to grab them before rebooting.

Comment 4 Pavel Holica 2014-11-14 15:23:09 UTC
Created attachment 957627 [details]
anaconda.log

Comment 5 Pavel Holica 2014-11-14 15:23:10 UTC
Created attachment 957628 [details]
ifcfg.log

Comment 6 Pavel Holica 2014-11-14 15:23:16 UTC
Created attachment 957629 [details]
packaging.log

Comment 7 Pavel Holica 2014-11-14 15:23:19 UTC
Created attachment 957630 [details]
program.log

Comment 8 Pavel Holica 2014-11-14 15:23:22 UTC
Created attachment 957631 [details]
storage.log

Comment 9 Pavel Holica 2014-11-14 15:23:24 UTC
Created attachment 957632 [details]
storage.state

Comment 10 Pavel Holica 2014-11-14 15:23:27 UTC
Created attachment 957633 [details]
syslog

Comment 11 Pavel Holica 2014-11-14 15:23:29 UTC
Created attachment 957634 [details]
X.log

Comment 12 Pavel Holica 2014-11-14 15:24:00 UTC
Sorry about missing logs. Here they are.

Comment 13 Samantha N. Bueno 2014-11-14 15:57:58 UTC
(In reply to Pavel Holica from comment #12)
> Sorry about missing logs. Here they are.

No worries.

So yeah, RHEL doesn't carry the version of systemd with the patch that is causing bug 1161644; ID_PATH is here in all its glory--

14:56:26,808 DEBUG blivet:             DeviceTree.addUdevDevice: info: {'DEVLINKS': '/dev/disk/by-id/scsi-1IET_00010001 /dev/disk/by-path/ip-10.0.0.1:3260-iscsi-iqn.2010-04.virt.nap:default-lun-1',
 'DEVNAME': 'sda',
 'DEVPATH': '/devices/platform/host2/session1/target2:0:0/2:0:0:1/block/sda',
 'DEVTYPE': 'disk',
 'DM_MULTIPATH_TIMESTAMP': '1415976948',
 'ID_BUS': 'scsi',
 'ID_MODEL': 'VIRTUAL-DISK',
 'ID_MODEL_ENC': 'VIRTUAL-DISK',
 'ID_PATH': 'ip-10.0.0.1:3260-iscsi-iqn.2010-04.virt.nap:default-lun-1',
 'ID_PATH_TAG': 'ip-10_0_0_1_3260-iscsi-iqn_2010-04_virt_nap_default-lun-1',
 'ID_REVISION': '0001',
 'ID_SCSI': '1',
 'ID_SCSI_SERIAL': 'beaf11',
 'ID_SERIAL': '1IET_00010001',
 'ID_SERIAL_SHORT': 'IET_00010001',
 'ID_TYPE': 'disk',
 'ID_VENDOR': 'IET',
 'ID_VENDOR_ENC': 'IET\\x20\\x20\\x20\\x20\\x20',
 'MAJOR': '8',
 'MINOR': '0',
 'MPATH_SBIN_PATH': '/sbin',
 'SUBSYSTEM': 'block',
 'TAGS': ':systemd:',
 'USEC_INITIALIZED': '55770477',
 'name': 'sda',
 'symlinks': ['/dev/disk/by-id/scsi-1IET_00010001',
              '/dev/disk/by-path/ip-10.0.0.1:3260-iscsi-iqn.2010-04.virt.nap:default-lun-1'],
 'sysfs_path': '/devices/platform/host2/session1/target2:0:0/2:0:0:1/block/sda'} ; name: sda ;

Comment 14 Pavel Holica 2015-02-10 10:16:04 UTC
I've just hit this again. So component of this bug should be systemd?

Comment 19 Pavel Holica 2015-08-26 09:44:04 UTC
Reproduced on RHEL-7.1 GA x86_64 Server
Verified fix on RHEL-7.2-20150820.0 x86_64 Server

Anaconda now complains about /boot being on iSCSI device and refuses to proceed with installation.

Comment 20 Radek Vykydal 2015-10-20 08:13:21 UTC
We should probably update Instsallation Guide, part

B.1. iSCSI Disks in Anaconda

with information that
/boot partition is allowed only on iSCSI targets configured and attached from iBFT configuration (as described in paragraph 1)

Comment 21 Radek Vykydal 2015-10-21 07:23:38 UTC
Can we open this BZ for Dell?
https://bugzilla.redhat.com/show_bug.cgi?id=1271938#c7

Comment 22 errata-xmlrpc 2015-11-19 09:48:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2284.html


Note You need to log in before you can comment on or make changes to this bug.