Bug 1164296 - Application crashes after many hours of drawing
Summary: Application crashes after many hours of drawing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libxcb
Version: 6.7
Hardware: i686
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Olivier Fourdan
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: OtherQA, Patch
Depends On:
Blocks: 1206240
TreeView+ depends on / blocked
 
Reported: 2014-11-14 15:18 UTC by Ashish Shah
Modified: 2019-07-11 08:21 UTC (History)
6 users (show)

(edit)
On 32-bit architectures, an X11 protocol client was under certain circumstances disconnected after processing a large number of X11 requests. With this update, the libxcb library exposes the request sequence number as a 64-bit integer so that libX11 can make use of 64-bit sequence number even on 32-bit systems. As a result, the described failure of the X11 client no longer occurs.
Clone Of:
: 1206245 (view as bug list)
(edit)
Last Closed: 2015-07-22 07:02:26 UTC


Attachments (Terms of Use)
Patch based on fix proposed in upstream bug (1.50 KB, patch)
2014-11-14 15:18 UTC, Ashish Shah
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1358 normal SHIPPED_LIVE libxcb and libX11 bug fix update 2015-07-20 17:59:26 UTC
Red Hat Knowledge Base (Solution) 1271843 None None None Never

Description Ashish Shah 2014-11-14 15:18:50 UTC
Created attachment 957626 [details]
Patch based on fix proposed in upstream bug

Description of problem:

Customer is concern that during the port of one of their systems to RHEL6.4 they may see below issue..
http://lists.x.org/archives/xorg-devel/2013-October/038370.html (as referenced in http://stackoverflow.com/questions/23871516/xreply-terminates-app-with-xioerror)

Version-Release number of selected component (if applicable):
libX11-1.5.0-4.el6.i686
libX11-1.6.0-2.2.el6.i686

How reproducible:

Always

Steps to Reproduce:
1. Download reproducer code from upstream bug - https://bugs.freedesktop.org/show_bug.cgi?id=71338
2. Compile and keep it running on 32-bit rhel6 system


Actual results:

Below problem is observed after around 5 hours of run..

./xdraw 
ERROR Received a X IO error on display=8ffe008.
backtrace() returned 10 addresses
./xdraw() [0x8048853]
./xdraw() [0x80488f4]
/usr/lib/libX11.so.6(_XIOError+0x57) [0x61dc797]
/usr/lib/libX11.so.6(_XReply+0x3d5) [0x61db055]
/usr/lib/libX11.so.6() [0x61dd34f]
/usr/lib/libX11.so.6() [0x61dd465]
/usr/lib/libX11.so.6(XDrawLine+0x9b) [0x61b937b]
./xdraw() [0x8048b3b]
/lib/libc.so.6(__libc_start_main+0xe6) [0x192d26]
./xdraw() [0x80487a1]


Expected results:

Application should not crash and should continue running without any problem.


Additional info:

I have verified locally that the parch from below link helps to resolve issue.
http://patchwork.freedesktop.org/patch/16297/

Comment 14 errata-xmlrpc 2015-07-22 07:02:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1358.html


Note You need to log in before you can comment on or make changes to this bug.