Bug 116445 - Remove JVM version probe
Remove JVM version probe
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
: 154047 (view as bug list)
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2004-02-20 22:32 EST by Sam Varshavchik
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 05:45:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2004-02-20 22:32:10 EST
Description of problem:

The following portion of /usr/bin/mozilla doesn't work on AMD64:

    # export this temporarily - it seems to work with old and new
    # versions of the JVM.
    export LD_ASSUME_KERNEL=2.2.5
 
    # get the version
    JVM_VERSION=`$JVM_COMMAND -version 2>&1 | grep version | cut -f 3
-d " " | sed -e 's/\"//g'`


The export must be commented out, otherwise both Sun's i586 VM, and
Blackdown's AMD64 VM break (Blackdown's has other issues, but it's
their problem).

Version-Release number of selected component (if applicable):

mozilla-1.4.1-18

How reproducible:

Always

Steps to Reproduce:

1. Go to java.sun.com, grab 1.4.2 JRE for i586, and install it.
2. Creating a soft link from /usr/lib/mozilla/plugins to
i386/ns610-gcc32/libjavaplugin_oji.so
3. Run /usr/bin/mozilla
  
Actual results:

[root@commodore tmp]# /usr/bin/mozilla
grep: error while loading shared libraries: libc.so.6: cannot open
shared object file: No such file or directory
cut: error while loading shared libraries: libc.so.6: cannot open
shared object file: No such file or directory
sed: error while loading shared libraries: libc.so.6: cannot open
shared object file: No such file or directory

The plugin does not get initialized

Expected results:

No output.

Additional info:

With the LD_ASSUME_KERNEL=2.2.5 commented out, Mozilla starts up
without reporting any errors, and the java plugin is visible in
about:plugins.
Comment 1 Justin M. Forbes 2004-02-22 23:37:28 EST
After the install did you add /etc/profile.d/java.sh appropriately? 
we currently ship with 32bit mozilla so the AMD64 Java plug-in wouldnt
work, but the Sun i586 works for me.
Comment 2 Sam Varshavchik 2004-02-23 07:11:23 EST
Neither Sun's, nor Blackdown's VM installs any custom profile
settings. Nor has it ever been necessary.  Sun's VM runs fine without
any custom settings.  The only issue is the Mozilla wrapper, which
sets LD_ASSUME_KERNEL, which messes up grep, cut, etc...
Comment 3 Christopher Blizzard 2004-03-05 15:24:09 EST
I'm tempted to pull that entire check out of our packages.  Since
those old jvms probably won't even work anymore.
Comment 4 Warren Togami 2005-04-25 04:03:43 EDT
x86_64 does not have a non-NPTL threading model, and in FC4+ LD_ASSUME_KERNEL is
useless.  It makes no sense to keep this hack in FC3+ and RHEL4+ mozilla and
firefox.

I personally will do more research into this to make 100% sure this is the right
thing to do.
Comment 5 Warren Togami 2005-04-27 22:32:42 EDT
*** Bug 154047 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2005-04-27 23:03:55 EDT
I can't think of any good reason to keep the JVM probing stuff in any FC3+ or
RHEL4+ package, it should be removed from FC4, and those other packages the next
time they are updated.
Comment 7 Warren Togami 2005-04-28 01:22:33 EDT
Committed to FC3, FC4, and RHEL4 firefox and mozilla.  thunderbird didn't have
it (probably because browser plugins aren't too useful there. =)  Will be in
next build... setting MODIFIED.
Comment 8 Warren Togami 2005-05-20 05:45:24 EDT
Fixed in all distributions now.

Note You need to log in before you can comment on or make changes to this bug.