Bug 1164627 - libvirt should forbid attach a unsupport console to a active vm
Summary: libvirt should forbid attach a unsupport console to a active vm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-17 03:14 UTC by Luyao Huang
Modified: 2015-11-19 05:55 UTC (History)
4 users (show)

Fixed In Version: libvirt-1.2.13-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:55:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2014-11-17 03:14:21 UTC
description of problem:
libvirt should forbid attach a unsupport console to a active vm

Version-Release number of selected component (if applicable):
libvirt-1.2.8-7.el7.x86_64


How reproducible:
100%

Steps to Reproduce:

1.# cat lxcconsole.xml
  <console type='pty'>
      <target type='lxc' port='1'/>
    </console>

2.# virsh list --all
 Id    Name                           State
----------------------------------------------------
 32    r6                             running

3.wrong in this step:

# virsh attach-device r6 lxcconsole.xml
Device attached successfully

4.can see it in vm's xml
# virsh dumpxml r6|grep -2 lxc
    <console type='pty'>
      <source path='/dev/pts/11'/>
      <target type='lxc' port='1'/>
      <alias name='console1'/>
    </console>

5.cannot detach after attach
# virsh detach-device r6 lxcconsole.xml --live
error: Failed to detach device from lxcconsole.xml
error: Requested operation is not valid: device not present in domain configuration


Actual results:
attach success

Expected results:
report error, this console is for lxc, if we try start a qemu guest with lsc console, will get error :

# virsh start r6
error: Failed to start domain r6
error: unsupported configuration: unsupported console target type lxc

So attach this console should report error.

Additional info:
No error in libvirtd.log.

Comment 1 Luyao Huang 2014-11-19 00:37:18 UTC
send a patch to upstream:

https://www.redhat.com/archives/libvir-list/2014-November/msg00556.html

Comment 2 Peter Krempa 2015-01-22 10:21:30 UTC
commit 860522d26b9bd532d4f77d057d85e847c84e6af5
Author: Luyao Huang <lhuang@redhat.com>
Date:   Thu Jan 22 10:28:18 2015 +0800

    qemu: output error when try to hotplug unsupported console type
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1164627
    
    When using 'virsh attach-device' to hotplug an unsupported console type
    into a qemu guest the attachment would succeed as the command line
    formatter didn't report error in such case.

v1.2.12-rc1-3-g860522d

Comment 5 Hu Jianwei 2015-05-07 06:18:54 UTC
Verified as below:

[root@localhost ~]# rpm -q libvirt qemu-kvm-rhev
libvirt-1.2.15-1.el7.x86_64
qemu-kvm-rhev-2.3.0-1.el7.x86_64

[root@localhost ~]# virsh list
 Id    Name                           State
----------------------------------------------------
 34    r71                            running

[root@localhost ~]# cat lxc.xml 
 <console type='pty'>
      <target type='lxc' port='1'/>
    </console>

[root@localhost ~]# virsh attach-device r71 lxc.xml 
error: Failed to attach device from lxc.xml
error: unsupported configuration: unsupported console target type lxc

Comment 7 errata-xmlrpc 2015-11-19 05:55:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.