Bug 1164691 - virt-manager cannot open after the input of a wrong guest uuid in command, and the related process will never quit unless killed.
Summary: virt-manager cannot open after the input of a wrong guest uuid in command, an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-17 07:28 UTC by Ye Lingfei
Modified: 2015-03-05 10:07 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.1.0-7.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:07:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Description Ye Lingfei 2014-11-17 07:28:28 UTC
Description of problem:
virt-manager cannot open after the input of a wrong guest uuid in command, and the related process will never quit unless killed.

Version-Release number of selected component (if applicable):
virt-manager-1.1.0-6.el7.noarch

How reproducible:
100%

Steps to Reproduce:
*make sure there is no virt-manager running on your host*
1. Input "virt-manager --show-domain-editor=1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd -c qemu:///system" in terminal
2. Input "virt-manager" in terminal

Actual results:
Step 1,
qemu:///system does not have VM '1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager", line 40, in <module>
    gi.check_version("3.9.1")
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 54, in check_version
    "%s is not recent enough") % (version, __version__)
ValueError: pygobject's version 3.9.1 required, and available version 3.8.2 is not recent enough

Step 2,
qemu:///system does not have VM '1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager", line 40, in <module>
    gi.check_version("3.9.1")
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 54, in check_version
    "%s is not recent enough") % (version, __version__)
ValueError: pygobject's version 3.9.1 required, and available version 3.8.2 is not recent enough  

What's more,
# ps -ef|grep virt-manager
root     12114     1  4 15:19 ?        00:00:00 /usr/bin/python2 -tt /usr/share/virt-manager/virt-manager --show-domain-editor=1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd -c qemu:///system
root     12250  8911  0 15:19 pts/5    00:00:00 grep --color=auto virt-manager
The process "virt-manager --show-domain-editor=1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd -c qemu:///system" will never quit unless killed.

Expected results:
Step 1, response the error info about the wrong guest uuid;
Step 2, open the virt-manager successfully, and the Virtual Machine Manager Window will pop up

Additional info:
If the wrong name or id is input with the command, there will also be the same problem.

Comment 2 Giuseppe Scrivano 2014-11-17 09:05:19 UTC
patch proposed upstream:

https://www.redhat.com/archives/virt-tools-list/2014-November/msg00083.html

Comment 5 Ye Lingfei 2014-11-19 07:23:20 UTC
I can reproduce with:
virt-manager-1.1.0-6.el7.noarch

VERIFY with:
virt-manager-1.1.0-7.el7.noarch

Steps:
With no virt-manager running on my host
1. Input "virt-manager --show-domain-editor=1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd -c qemu:///system" in terminal
2. Input "virt-manager" in terminal

Result:
After Step 1, come out the error info:
qemu:///system does not have VM '1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd'

Traceback (most recent call last):
File "/usr/share/virt-manager/virt-manager", line 40, in <module>
gi.check_version("3.9.1")
File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 54, in check_version
"%s is not recent enough") % (version, version)
ValueError: pygobject's version 3.9.1 required, and available version 3.8.2 is not recent enough
Close the info window, input "ps -ef|grep virt-manager" in terminal

#ps -ef|grep virt-manager
root 9255 3487 0 13:43 pts/0 00:00:00 grep --color=auto virt-manager

The related process has quit.

After step 2:
Can open the virt-manager successfully, and the Virtual Machine Manager Window can pop up.

As the result, set VERIFIED.

But I have some question about the error info mentioned above. 
As you can see, the "details" part of the error info seems to be irrelevant to the problem the user has encountered. I think the details should explain to users what's the problem directly.
So I'd like to inform you of this possible problem.
Thank you.

Comment 6 Giuseppe Scrivano 2014-11-19 08:40:00 UTC
I think we can leave the details as they are now, in any case the user is notified that the VM could not be found.

Comment 7 Ye Lingfei 2014-11-20 01:50:25 UTC
According to Comment 5 and Comment 6, set verified.

Comment 9 errata-xmlrpc 2015-03-05 10:07:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.