Bug 116473 - Incorrect error reporting on transfer error
Summary: Incorrect error reporting on transfer error
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: up2date-fc2
TreeView+ depends on / blocked
 
Reported: 2004-02-21 15:49 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 17:55:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-02-21 15:49:15 UTC
If a file transfer fails part way through then up2date reports a GPG
signature error and starts suggesting scary things like the package
having been tampered with. It should be reporting the failed transfer
instead

Comment 1 Andre Robatino 2004-03-14 03:00:38 UTC
  This bug has been around for about 2 years now.  It would be nice if
it could actually resume the download automatically (if necessary
switching mirrors).  This not only saves on bandwidth, but if someone
is on dialup, needs to download a large package (I've seen 40 MB) and
is unable/unwilling to wait long enough (for example if their ISP
imposes a time limit), they need this feature.  I get the impression
that the keepers of the code are hoping that using mirrors will make
this stop manifesting, so it doesn't need to be fixed.  Not only is
this bad programming practice (bugs should be fixed while they're
obvious, otherwise they never get fixed and do damage forever), but as
I pointed out above some people need to break up their downloads, even
if the server doesn't quit.
  If resuming downloads isn't implemented, then at least the error
message needs to be changed, so people know what's going on (maybe
this will increase pressure to fix it, too).  I've seen a fedora-list
message where someone actually reinstalled because the GPG signature
message led them to believe that their current install was corrupt! 
Not to mention the countless duplicate bug reports, like this one,
which are typically ignored.

Comment 3 Alan Cox 2004-10-01 22:51:48 UTC
Switched to yum, would suggest anyone else does the same if they hit this.


Comment 4 Alan Cox 2006-06-06 17:55:05 UTC
FC thankfully now uses yum not up2date. Closing as obsolete



Note You need to log in before you can comment on or make changes to this bug.