Bug 1164733 (CVE-2014-3693) - CVE-2014-3693 libreoffice: Use-After-Free in socket manager of Impress Remote
Summary: CVE-2014-3693 libreoffice: Use-After-Free in socket manager of Impress Remote
Keywords:
Status: NEW
Alias: CVE-2014-3693
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1164736 1167503
Blocks: 1121513 1160961
TreeView+ depends on / blocked
 
Reported: 2014-11-17 09:19 UTC by Huzaifa S. Sidhpurwala
Modified: 2020-03-04 11:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A use-after-free flaw was found in the "Remote Control" capabilities of the LibreOffice Impress application. An attacker could use this flaw to remotely execute code with the permissions of the user running LibreOffice Impress.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:0377 normal SHIPPED_LIVE Moderate: libreoffice security, bug fix, and enhancement update 2015-03-05 13:48:57 UTC

Description Huzaifa S. Sidhpurwala 2014-11-17 09:19:08 UTC
As per upstream libreoffice advisory:

In LibreOffice 4.0.0 and later, a new feature was added for remote control capabilities in Impress. Users can run a smart phone
application to communicate with Impress over a custom protocol to switch slides and the like. By default whenever Impress is started, it immediately began listening on TCP port 1599 on all interfaces.

But there was a use after free bug in the code managing that port leaving LibreOffice vulnerable to  external attackers with access to that port where those external attackers could cause the deleted port manager to continue to process attacker supplied data.

All users are recommended to upgrade to LibreOffice 4.2.7 or 4.3.3.

The impress remote can be disabled by:

1. Open LibreOffice, go to "Tools -> Options..."
2. Select "LibreOffice Impress -> General"
3. Uncheck "Presentation -> Enable remote control"

External References:

http://www.libreoffice.org/about-us/security/advisories/cve-2014-3693

Comment 2 Murray McAllister 2014-11-24 23:51:11 UTC
Created libreoffice tracking bugs for this issue:

Affects: fedora-all [bug 1167503]

Comment 3 Huzaifa S. Sidhpurwala 2014-11-26 06:46:17 UTC
Statement:

This issue affects the versions of libreoffice as shipped with Red Hat Enterprise Linux 6. Red Hat Product Security has rated this issue as having Moderate security impact. A future update may address this issue.

Comment 5 errata-xmlrpc 2015-03-05 08:51:05 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2015:0377 https://rhn.redhat.com/errata/RHSA-2015-0377.html


Note You need to log in before you can comment on or make changes to this bug.