Bug 1164734 - The description of 'help append' is not accurately, it add the kernel options to libguestfs appliance not the guest kernel
Summary: The description of 'help append' is not accurately, it add the kernel options...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1164732
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-17 09:19 UTC by Lingfei Kong
Modified: 2015-07-22 05:56 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.20.11-12.el6
Doc Type: Enhancement
Doc Text:
Minor fixes and improvements have been done to the help message of the "set-append" command, an error message of the "guestfish umount" command, and to the guestfish(1) and virt-edit(1) man pages.
Clone Of: 1164732
Environment:
Last Closed: 2015-07-22 05:56:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-11-17 09:19:24 UTC
+++ This bug was initially created as a clone of Bug #1164732 +++

Description of problem:
The description of 'help append' is not accurately, it add the kernel options to libguestfs appliance not the guest kernel


Version-Release number of selected component (if applicable):
libguestfs-1.28.1-1.10.el7


How reproducible:
100%


Steps to Reproduce:
1. Prepare a image file
# dd if=/dev/zero  of=test.img bs=1M count=1 seek=100

2. # guestfish  -a test.img
><fs> set-append test=TEST
><fs> run
><fs> debug sh "cat /proc/cmdline"
panic=1 console=ttyS0 udevtimeout=6000 udev.event-timeout=6000 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sda selinux=0 TERM=xterm-256color test=TEST


Actual results:


Expected results:


Additional info:

Comment 1 Richard W.M. Jones 2014-11-17 10:08:35 UTC
Upstream fix is 6dd371f913332a840b34ad00d52e9fa52711fb0e.

Comment 3 Chao Zhang 2014-12-11 09:11:08 UTC
Verify with libguestfs-1.20.11-12.el6

Steps:

#guestfish
><fs> help append
NAME
    set-append - add options to kernel command line

Comment 6 errata-xmlrpc 2015-07-22 05:56:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.