Bug 1164753 - redhat-support-plugin-rhev-3.5.0-1 breaks yum update
Summary: redhat-support-plugin-rhev-3.5.0-1 breaks yum update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Jiri Belka
URL:
Whiteboard: integration
: 1168215 (view as bug list)
Depends On:
Blocks: 1162189 rhev35rcblocker rhev35gablocker 1168936 1184995
TreeView+ depends on / blocked
 
Reported: 2014-11-17 10:47 UTC by Sandro Bonazzola
Modified: 2015-02-16 15:42 UTC (History)
17 users (show)

Fixed In Version: rhevm-setup-plugins-3.5.0-3.el6ev
Doc Type: Bug Fix
Doc Text:
With this update, rhevm-setup-plugins now adds redhat-support-plugin-rhev to version locking, allowing users to run "yum update" without errors when Red Hat Enterprise Virtualization 3.4.5 is installed and the Red Hat Enterprise Virtualization 3.5.0 channel is available.
Clone Of:
: 1168936 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:45:40 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0196 normal SHIPPED_LIVE rhevm-setup-plugins bug fix and enhancement update 2015-02-11 22:35:33 UTC

Description Sandro Bonazzola 2014-11-17 10:47:07 UTC
redhat-support-plugin-rhev was supposed to be backward compatible and not needing version locking anymore, so just Requires: rhevm >= 3.4.0 should have been enough.

yum update now shows:

Error: Package: redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch (qa-latest-vt)
           Requires: rhevm >= 3.5.0
           Installed: rhevm-3.4.4-2.2.el6ev.noarch (@qa-latest-av)
               rhevm = 3.4.4-2.2.el6ev
 You could try using --skip-broken to work around the problem

So either requires rhevm >= 3.4.0 in redhat-support-plugin-rhev or re-introduce version-locking in rhevm-3.4.5.

Not using high severity because workaround exist:
 yum update "rhevm-setup*" 
 engine-setup
and engine setup will take care of the rest.

Comment 1 Spenser Shumaker 2014-11-17 15:28:29 UTC
Sandro, the fix for this is to version lock the plugin in the engine RPM, correct?  Who owns the version locking?

Comment 2 Sandro Bonazzola 2014-11-17 15:34:05 UTC
If we need to version lock it because backward compatibility is not available, we need to change rhevm-setup-plugins to support it.

Comment 3 Keith Robertson 2014-11-27 14:26:41 UTC
*** Bug 1168215 has been marked as a duplicate of this bug. ***

Comment 4 Keith Robertson 2014-11-27 14:29:35 UTC
(In reply to Sandro Bonazzola from comment #2)
> If we need to version lock it because backward compatibility is not
> available, we need to change rhevm-setup-plugins to support it.

IIRC, we agreed on version locking for the plug-in since 3.3.  Please make the change in rhevm-setup-plugins.

Comment 5 Sandro Bonazzola 2014-11-27 15:20:43 UTC
(In reply to Keith Robertson from comment #4)
> (In reply to Sandro Bonazzola from comment #2)
> > If we need to version lock it because backward compatibility is not
> > available, we need to change rhevm-setup-plugins to support it.
> 
> IIRC, we agreed on version locking for the plug-in since 3.3.  Please make
> the change in rhevm-setup-plugins.

Not really.
Version locking has been added in 3.2.5 for allowing a safe upgrade to 3.3.0.
3.3.0 remove the locking on the package and so far upgrade from 3.3 to 3.4 is not using the version locking.

Now looks like we have too re-introduce the dropped version locking for upgrading from 3.4 to 3.5, and I'm fine with re-introducing it, it's just a bit late in the process.

This means we need to change 3.4.5 setup-plugin too.

Comment 8 Jiri Belka 2014-12-16 16:21:25 UTC
ok, rhevm-setup-plugins-3.5.0-3.el6ev.noarch.rpm\

then redhat-support-plugin-rhev appears in versionlock.list if it was not already there

Comment 9 Gil Klein 2015-01-14 05:37:31 UTC
Sandro, I still see this issue when trying to "yum update" from 3.4.4 (av13.3) -> 3.5.0 (vt13.7)

[root@rhevm-3 yum.repos.d]# rpm -qi rhevm
Name        : rhevm                        Relocations: (not relocatable)
Version     : 3.4.4                             Vendor: Red Hat, Inc.
Release     : 2.2.el6ev                     Build Date: Tue 11 Nov 2014 01:18:49 AM IST

After yum update, I got:

Error: Package: redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch (vt13.7)
           Requires: rhevm >= 3.5.0
           Installed: rhevm-3.4.4-2.2.el6ev.noarch (@v13.3)
               rhevm = 3.4.4-2.2.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 10 Gil Klein 2015-01-14 06:47:44 UTC
My bad, It works just fine as soon as I've upgraded to 3.4.5.

Comment 12 errata-xmlrpc 2015-02-11 17:45:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0196.html


Note You need to log in before you can comment on or make changes to this bug.