Bug 116488 - gnome-file-types-properties crashes when launched from nautilus
Summary: gnome-file-types-properties crashes when launched from nautilus
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-21 18:03 UTC by Justin Georgeson
Modified: 2013-04-02 04:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-17 10:45:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Georgeson 2004-02-21 18:03:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
If I open a file in Nautilus for which there is no configured
apploication, I am prompted to either Associate Application or Cancel.
If I click the button to Associate Application, I am presented with a
crash window for gnome-file-types-properties. This seems to be limited
to certain files or file types. Specific files this has been
consistent on are /usr/share/alsa/asla.conf and
/usr/share/alsa/sndo-mixer.alisp. A file which Nautilus has not given
me the crash dialog for, but has still failed to launch the
gnome-file-type-properties application, are
/usr/share/doc/alsa-utils-1.0.2. This happens in both Browse view, and
whatever the new default behavior for Nautilus is called.

Version-Release number of selected component (if applicable):
control-center-2.5.2-5

How reproducible:
Always

Steps to Reproduce:
1. Open Nautilus and navigate to /usr/share/alsa
2. Click, or double-click depending on settings, on alsa.conf
3. Click the button for Associate Application
    

Actual Results:  a crash dialog is presented, giving me the option to
dismiss or file a bug report.

Expected Results:  gnome-file-type-properties should launch so I can
associate an application.

Additional info:

Comment 1 Justin Georgeson 2004-02-21 18:04:19 UTC
Ugh, should have previewed better, the file which doesn't crash, but
also doesn't launch gnome-file-types-properties, is
/usr/share/doc/alsa-utils-1.0.2.

Comment 2 Justin Georgeson 2004-02-28 07:52:41 UTC
Well, I guess bugzilla just doesn't like the filename I gave it. I
think it was c hangelog. Anyhow, all those files listed have mime
types for them now after updating what seems like everything.
control-center is now at 2.5.3-1 and I haven't found a file yet to
crash it. Consider it fixed.

Comment 3 Peter Backlund 2004-02-28 09:29:55 UTC
I've seen this issue with .spec not being associated, making Nautilus
segfault. Can't reproduce it anymore, so I also think it has been
fixed by now. 

Comment 4 Alexander Larsson 2004-03-19 11:14:29 UTC
I think this was fixed with a recent nautilus upgrade.

Comment 5 Justin Georgeson 2004-03-19 16:01:49 UTC
I know I tested this after a big update a while ago, and seem to
remember adding a comment that it had been fixed, but I don't see that
comment. So I agree, I think it has been fixed.


Note You need to log in before you can comment on or make changes to this bug.