Bug 1164916 - mod_cluster doesn't recognize ; as a proper context delimiter causing 404s on requests with URL jsessionids
Summary: mod_cluster doesn't recognize ; as a proper context delimiter causing 404s on...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: mod_cluster
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER2
: EAP 6.4.0
Assignee: Jean-frederic Clere
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Depends On:
Blocks: 1181106
TreeView+ depends on / blocked
 
Reported: 2014-11-17 21:22 UTC by Aaron Ogburn
Modified: 2019-08-19 12:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 12:42:48 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker MODCLUSTER-443 0 Major Resolved mod_cluster doesn't recognize ; as a proper context delimiter causing 404s on requests with URL jsessionids 2017-03-01 14:04:18 UTC

Description Aaron Ogburn 2014-11-17 21:22:16 UTC
Description of problem:

mod_cluster does not recognize ; as a delimiter when checking the request context. Thus with no trailing slash on index page requests, it treats ;jsessionid as part of the request context and tries to check the balancer for a deployed context of /helloworld;jsessionid=..., which doesn't exist and 404s. Adding the trailing slash, mod_cluster can properly delimit this and then sees the context (so /helloworld/;jsessionid=... works just fine).

Version-Release number of selected component (if applicable):

1.2.10.Alpha


How reproducible:

Always


Steps to Reproduce:
1. Deploy /helloworld in a mod_cluster set up
2. Request "/helloworld;jsessionid=bla" through httpd

Actual results:

A 404 is returned

Expected results:

The request is served

Additional info:

Comment 1 Aaron Ogburn 2014-11-17 21:23:28 UTC
PR: https://github.com/modcluster/mod_cluster/pull/132

Comment 3 Michal Karm Babacek 2014-12-09 12:05:41 UTC
Needs an upgrade to mod_cluster 1.2.11.Final

Comment 4 Michal Karm Babacek 2014-12-09 13:33:11 UTC
Escalating Severity due to the pending customer case.

Comment 5 Michal Karm Babacek 2014-12-09 15:26:31 UTC
Switching to MODIFIED, the patch has been merged.

Comment 6 Michal Karm Babacek 2015-01-12 08:57:39 UTC
mod_cluster component hasn't been upgraded to 1.2.11.Final.
This fix ain't present in EAP 6.4.0.ER1.

Comment 7 Kabir Khan 2015-01-15 19:57:32 UTC
Fixed by 1.2.11 upgrade

Comment 8 Radim Hatlapatka 2015-02-10 15:51:39 UTC
Verified with EAP 6.4.0.ER2


Note You need to log in before you can comment on or make changes to this bug.