Bug 116510 - After mounting any OS's(other than a RHEL 3 NFS server) nfs version 3 server, our RHEL 3 ws update one nfs client hangs
After mounting any OS's(other than a RHEL 3 NFS server) nfs version 3 server,...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Layton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 22:21 EST by Brent Clements
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The ethereal capture of rhew 3 client trying to mount hpux nfs server (6.85 KB, application/octet-stream)
2004-04-06 17:20 EDT, Brent Clements
no flags Details
Ethereal trace of an "hanged" NFS connection (RHEL 3 - RedHat 9) (34.73 KB, application/octet-stream)
2004-05-24 05:21 EDT, Didier Belhomme
no flags Details

  None (edit)
Description Brent Clements 2004-02-21 22:21:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; YComp 
5.0.0.0; .NET CLR 1.1.4322)

Description of problem:
This is the scenario.

We have an HP-UX NFS server. After mounting the NFS server 
successfully using our newly installed RHEL 3 WS(ia64), we try to do 
an ls on the mounted directory and the system hangs. We can 
successfully mount the HP-UX nfs server using any other os and/or 
linux distribution.

We thought it may be an incompatibility between RHEL 3 and HPUX so we 
did the following. We have exported filesystems from a RH AW 2.1 
machine and can successfully mount the directory, but when we try to 
perform any access on the mounted directory it hangs. Any other 
OS/Distribution can successfully mount and access the RH AW 2.1 NFS 
Server.

No firewall rulesets are setup on any of the boxes.  

The wierd thing is this: We installed another RHEL 3 WS on another 
machine and both RHEL 3 WS machine can mount and access each other. 

So it looks like RHEL 3 WS IA64 can only mount and access another 
RHEL 3 WS/AS. 

We have made sure that firewall rulesets are disabled and that UDP is 
being used to mount. 

This is holding up our upgrade since our central NFS server is HP-UX. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Mount any remote NFS SERVER that is not RHEL 3 based to /tmp/test
2. cd /tmp/test
3. ls


    

Actual Results:  It Hangs

Expected Results:  We should be able to successfully mount and access 
a mounted directory.

Additional info:
Comment 1 Steve Dickson 2004-04-06 16:32:59 EDT
Would it be possible to post a bzip2-ed ethereal trace of the hang?
Comment 2 Brent Clements 2004-04-06 17:20:22 EDT
Created attachment 99161 [details]
The ethereal capture of rhew 3 client trying to mount hpux nfs server
Comment 3 Steve Dickson 2004-04-07 10:04:04 EDT
It seems to be hanging on a readdirplus call to the server.
Is there any type of errors being logged on the server?
Comment 4 Brent Clements 2004-04-07 10:48:16 EDT
No messages are being generated on the server and we have turned on
debugging on the hpux box's nfs subsystem.
Comment 5 Steve Dickson 2004-04-07 11:37:31 EDT
Ok... But this really looks like a server problem... Please
send HP the ethereal trace and ask them why they are not
responding to our readdirplus request... 

Comment 6 Brent Clements 2004-04-07 11:49:42 EDT
I am going to have to disagree with you on this one.

Like I said in the original bug report, we made one of our RHAW 2.1
machines an NFS server, we exported a directory from the RHAW 2.1 box. 

We tried mounting the RHAW ia64 2.1 box using the RHEL 3 ia64 client,
and it was the SAME EXACT PROBLEM. So the problem is NOT with the HPUX
server. It is with the RHEL 3 ia64 client machine. Like I also said,
the only thing a RHEL 3 i64 client can mount is another RHEL 3 ia64
nfs server.
Comment 7 Steve Dickson 2004-04-08 07:25:14 EDT
Ok...  I would like to handle this as two different problems.
So could you please post the ethereal trace of the RHEL3
client to AS21 server hang.

Obviously this does not happen in our testing, so I'm very
curious as to why this hang is occurring.... 
Comment 8 Didier Belhomme 2004-04-29 06:37:23 EDT
I'm experimenting the same problem on a RHEL 3 ES on i686 platform,
mounting a NFS-exported directory from a RedHat 9 Server. The NFS
client just hang for a few minutes, then recover and (sometimes)
cancel the copy. All I see when the client is hung is a few "UDP
fragment" for NFS between the server and the client.
Comment 9 Sameh Attia 2004-05-19 05:20:36 EDT
I have this same exact problem with a NAS storage running Windows 
2003 from Dell. 
Comment 10 Didier Belhomme 2004-05-24 05:21:44 EDT
Created attachment 100487 [details]
Ethereal trace of an "hanged" NFS connection (RHEL 3 - RedHat 9)
Comment 11 Didier Belhomme 2004-05-24 05:23:07 EDT
I've just uploaded an Ethereal trace of a "hanged" NFS mount. There
are bunchs of about 7 UDP datagram every few seconds, but the file
transfert is not advancing.
Comment 12 James Boyle 2004-08-03 15:31:21 EDT
[problem on i386 also]

I have a possibly related issue where mounting a an NFS share on a
RHEL-3.0 AS server works well, then after some time, on the nfs client
running ls -l /path/to/share results in ls hanging and remains
unkillable, even with kill -9.  Adding "intr" to the mount options
prevents the unkillable situation, but the problem still occurs.  The
nfs-client is an almost identical RHEL-3.0 AS box.  The "local"
storage on the nfs server is an EMC CX600 device mounted through EMC's
/dev/emcpower[x] special device.  At all times, the entire subtree of
the share on the server is accessible, i.e., (nfs-server)% ls -alR
/nfs/exported/dir, successfully returns all subdirs/files.

Furthermore, shell scripts residing on the nfs share can be run even
though doing "ls script.sh" will hang...  hard....

-jb
Comment 13 David 2004-11-17 15:29:42 EST
The same problem occurs when mounting disks from a Debian 3-Ware RAID
server to RHEL (Xeon/P4) clients. We moved the server to Debian
because of another bug:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121434

but this apparently means we'll have to go back to using RHEL for the
server.
Comment 14 Jeff Layton 2007-07-17 06:59:24 EDT
Is this still an issue on recent RHEL3? Say, RHEL3U9?
Comment 15 RHEL Product and Program Management 2007-10-19 15:29:57 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.