Bug 116513 - GcalcTool 4.3.3 not computing percents
Summary: GcalcTool 4.3.3 not computing percents
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils   
(Show other bugs)
Version: 1
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-22 04:54 UTC by Doug Maurer
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 19:28:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doug Maurer 2004-02-22 04:54:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have tried this on both a i686 laptop and athlon desktop. When
computing a percentage of a number; all it does is multiply the
number.  when doing 100 * 10% it should give a number of .1, but
instead it multiplies the number 100*10 %  and gives the answer of 1000.

Version-Release number of selected component (if applicable):
GcalcTool 4.3.3

How reproducible:
Always

Steps to Reproduce:
1. bring up calculator
2. press any number (ie.100)
3. hit the times sign (*)
4. press another number (ie. 10)
5. then press the percent sign (%)


Actual Results:  when pressing the % sign it acts like your pressing
the equals button

Expected Results:  to give a percentage of the number

Additional info:

Comment 1 Bart Martens 2004-02-22 15:00:29 UTC
I reproduced the problem with gnome-utils-2.4.0-1. Change the
component to gnome-utils please.


Comment 2 Bart Martens 2004-02-22 18:32:16 UTC
I suggest we continue discussing this bug upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=135140
Doug, there is already a patch available. I suggest you test it, and
comment your test results on the upstream bug report.


Comment 3 Bart Martens 2004-02-23 05:22:13 UTC
Not a bug. See upstream.


Comment 4 Jef Spaleta 2004-02-25 19:28:59 UTC
as seen upstream, this is not a bug...or if it is its a 10+ year old bug.


Note You need to log in before you can comment on or make changes to this bug.