Bug 1165133 - logrotate script in glusterfs package tries to rotate non-existant directories
Summary: logrotate script in glusterfs package tries to rotate non-existant directories
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Jan-Hendrik Zab
QA Contact:
URL:
Whiteboard:
: 1170814 (view as bug list)
Depends On: 1170825
Blocks: glusterfs-3.6.2
TreeView+ depends on / blocked
 
Reported: 2014-11-18 12:13 UTC by Nils Breunese
Modified: 2016-02-04 15:08 UTC (History)
4 users (show)

Fixed In Version: glusterfs-v3.6.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-04 15:08:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nils Breunese 2014-11-18 12:13:59 UTC
Description of problem:

The glusterfs package installs /etc/logrotate.d/glusterfs-georep, which tries to rotate files in directories under /var/log/glusterfs/geo-replication-slaves, which does not exist and therefor causes an error message.

Version-Release number of selected component (if applicable):

glusterfs-3.6.1-1.el7.x86_64

How reproducible:

Always.

Steps to Reproduce:

1. Install the glusterfs-3.6.1-1.el7.x86_64 package
2. Have logrotate do its thing

Actual results:

----
error: glusterfs-georep:31 glob failed for /var/log/glusterfs/geo-replication-slaves/*/*.log: No such file or directory
error: found error in file glusterfs-georep, skipping
----

Expected results:

No error messages.

Additional info:

The /etc/logrotate.d/glusterfs-georep file should maybe moved to the glusterfs-geo-replication package? It sounds like it belongs there.

Comment 1 Anand Avati 2014-12-11 07:38:16 UTC
REVIEW: http://review.gluster.org/9239 (Stop logrotate from complaining about missing files.) posted (#3) for review on release-3.6 by Lalatendu Mohanty (lmohanty@redhat.com)

Comment 2 Lalatendu Mohanty 2014-12-11 07:39:55 UTC
*** Bug 1170814 has been marked as a duplicate of this bug. ***

Comment 3 Anand Avati 2014-12-13 06:05:41 UTC
COMMIT: http://review.gluster.org/9239 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit dd0342ded4c793210c390e97d40b338321ec5151
Author: Jan-Hendrik Zab <zab@l3s.de>
Date:   Thu Dec 4 23:41:09 2014 +0100

    Stop logrotate from complaining about missing files.
    
    Previously logrotate reported errors for files missing in
    "/var/log/glusterfs/geo-replication-slaves/*/*.log". Fixed by reordering
    directives in the example config.
    
    Change-Id: I7cdb9e0d82f08aa27d5e26664660204fdeb8e98e
    BUG: 1165133
    Signed-off-by: Jan-Hendrik Zab <zab@l3s.de>
    Reviewed-on: http://review.gluster.org/9239
    Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 4 Kaushal 2016-02-04 15:08:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.2, please open a new bug report.

glusterfs-v3.6.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2015/01/glusterfs-3-6-2-ga-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.