Bug 116516 - Gimp prints empty printouts
Gimp prints empty printouts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp-print (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-22 06:50 EST by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.2.6-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 11:37:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2004-02-22 06:50:45 EST
Description of problem:
Trying to print from Gimp doesn't work

Version-Release number of selected component (if applicable):
gimp-2.0-0.pre3.3
gimp-print-4.2.6-7

How reproducible:
100%

Steps to Reproduce:
1.Archive->print
2.Click print
  
Actual results:
The file pops up for half a second in my printer queue and then
disappears again without trace.
Printing to file produces a zero-sized file.

Additional info:
It doesn't seem to matter what I input in Gimp's printer config options.
Comment 1 Nils Philippsen 2004-02-22 13:45:09 EST
Please try to reproduce this with the currently available packages,
namely gimp-2.0-1.pre3.4.

I just tried it on a full-resolution scan of a slide and got a print
which perfectly showed me that my laser printer a) is absolutely not
suitable for that type of images to print and b) is in need for a new
fuser unit.

I'll transfer this bug to gimp-print and try to anticipate Tim's question:

What printer model do you have?
Comment 2 Daniel Malmgren 2004-02-23 12:57:03 EST
Same result on pre3.4. My printer is a hp psc 1110, using the hpijs
driver. I very much doubt that it has anything with my printer to do
though because

1. Printing to file produces an empty file. No printer involved there.
2. No other program has any problem printing on the printer.

I might note that the preview in the gimp-print screen shows the image
perfectly allright.

Is there any way to get any debug output from gimp-print?
Comment 3 Tim Waugh 2004-02-23 14:46:06 EST
I don't understand -- what printer model do you have selected in the
'Printer Model' part of the 'Setup Printer' dialog?  PostScript Level 2?
Comment 4 Daniel Malmgren 2004-02-23 15:39:47 EST
As I said above this happens no matter what I input in the config
options of gimp-print. I've tried ps level 1, 2 and some of the
printers in the list (since my printer isn't listed, I can't try
that), it makes absolutely no difference.
Comment 5 Bill Nottingham 2004-02-23 18:28:34 EST
With an Epson Stylus C84, I was getting segfaults from the printing
subprocess. I'll try and reproduce later.
Comment 6 Tim Waugh 2004-02-27 08:22:18 EST
I think segfaults might be a different bug.

The empty output seems to be this:

 is not a valid dither algorithm

which comes from gimp-print-4.2.6/src/main/print-util.c:1479.
Comment 7 Daniel Malmgren 2004-02-27 08:44:07 EST
Yep. Seems like you're right. When changing dithering (from the
default adaptive hybride) printing works just fine!
Comment 8 Tim Waugh 2004-02-27 10:09:13 EST
Dither algorithm selection fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.