Bug 116517 - ESD will degrade sound volume when it changes frequency (filtering)
ESD will degrade sound volume when it changes frequency (filtering)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-22 08:40 EST by Dimitris
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-08 12:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2004-02-22 08:40:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I've noticed that when i play some types of audio or viode files,
the generated volume is very low.

I searched around and i think the problem is with ESD when the
original stream frequency is converted. For example, in mplayer
when i see this:

Building audio filter chain for 48000Hz/2ch/16bit -> 44100Hz/2ch/16bit...

The resulting audio has an extremely low volume.

When i change the mplayer configuration to use the SDL filtering
as the audio device, then audio plays fine without any loss
in volume.



Version-Release number of selected component (if applicable):
esound-0.2.31-1

How reproducible:
Always

Steps to Reproduce:
1. Find an audio stream which requires filtering (48khz to 44khz)
2. Play with mplayer via esd
3. Play with mplayer via SDL
    

Actual Results:  Via esd the audio volume is very low.

Via SDL/ALSA the audio volume is normal.


Expected Results:  Volume should be consistent.


Additional info:

none
Comment 1 Dimitris 2004-02-24 04:09:36 EST
I found a work-around to this problem:

1) i edited /etc/esd.conf
2) and added "-r 48000" in the spawn options

As a result, all output is 48khz so esd will
never do any downsampling, thus will not
lower the volume.

Its not a real solution though, since downsampling
shouldnt affect the volume, so the bug is still there.
Comment 2 Dimitris 2004-08-08 12:11:48 EDT
No answer. closing.

Note You need to log in before you can comment on or make changes to this bug.