Bug 116525 - RFE: dmidecode 2.5
RFE: dmidecode 2.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Jones
http://www.nongnu.org/dmidecode/
: FutureFeature
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-22 13:34 EST by acount closed by user
Modified: 2015-01-04 17:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:06:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2004-02-22 13:34:41 EST
Version 2.3 of dmidecode has just been released. Improvements include
support of x86_64 systems, support of systems with 2 GB and more
memory, and a load of bug fixes and corrections. A new tool,
vpddecode, is also included, which can be used to display the "vital
product data" structure found in IBM computers.

kernel-utils.spec has a "ExcludeArch:    ia64" field but it also runs
on IA-64. Maybe dmidecode should have a own RPM package.

-thanks-
Comment 1 Bill Nottingham 2004-02-23 18:30:58 EST
Whether dmidecode works on ia64 is actually rather bios specific; some
support it, some don't. (Unless there's been more specific changes in
that area.)
Comment 2 acount closed by user 2004-02-23 19:25:34 EST
http://savannah.nongnu.org/cgi-bin/viewcvs/*checkout*/dmidecode/dmidecode/README?rev=HEAD&content-type=text/plain

--dmidecode.README--

IA-64

Dmidecode used to have problems on IA-64 systems. The first reason for
this is that dmidecode accesses the DMI table through /dev/mem, and
reading
this file on an IA-64 system sometimes leads to a crash. A second
reason is
that the method for locating the above-mentioned table differs on IA-64
(compared to x86), so dmidecode was likely to miss the table entry point.
This complex issue was reported by Glen Foster and Smith Chad from HP. We
have since been working on a solution, and dmidecode now supports IA-64
systems. Smith Chad noticed that, for some obscure reason, accessing the
/dev/mem file using mmap() instead of read() would work. Then, he wrote a
patch to export the DMI table address from the internal EFI table to
/proc,
so dmidecode doesn't have to scan /dev/mem for it anymore. This patch was
since integrated into the main ia64 patch. Finally, I added the required
code to make it all work. So, in order to have dmidecode work on your
IA-64
system, you need two things:
 - dmidecode version 2.2 or later;
 - an ia64 patched kernel, using linux-2.4.21-ia64-030702.diff or any
later
   version.
Chad Smith tested dmidecode successfully on two different IA-64
systems, and
successes have been reported by other users too.
Comment 3 acount closed by user 2004-08-07 13:56:13 EDT
2.4 is out.
Comment 4 Robert Scheck 2004-10-14 10:05:09 EDT
dmidecode 2.4 should be included into the kernel-utils rather than 
the old 2.2.
Comment 5 acount closed by user 2004-11-08 19:34:42 EST
nobody cared, maybe the next century. Closing...
Comment 6 Marcin Garski 2004-11-30 07:07:09 EST
I reopen this bug because, now it's the perfect time to update
dmidecode (after FC3 release).

Why to update dmidecode:
- Bug #112355 someone using RHEL have problems with old dmidecode that
are resolved in newer version. Because RHEL is build on FC base,
dmidecode should be updated (why to update it only in RHEL?)
- Bug #127470 #117983 #117983 #128673 #135564 - Newer version *can*
resolve some of this bugs.
Comment 7 Dave Jones 2005-01-10 20:06:02 EST
done for tomorrows rawhide.

Note You need to log in before you can comment on or make changes to this bug.