Bug 11654 - Logrotate doesn't handle files with spaces correctly
Summary: Logrotate doesn't handle files with spaces correctly
Status: CLOSED DUPLICATE of bug 7999
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-25 08:45 UTC by André Johansen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-26 15:14:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description André Johansen 2000-05-25 08:45:08 UTC
Samba installs a configuration file that logrotate uses to rotate the Samba logs.
If people are running Windows, the Windows-name of the machine is used as part of
the filename for the log-files for Samba. logrotate does not handle this space;
this is a cron-message i get from cron.daily:

error: bad line 46 in state file /var/lib/logrotate.status

and that line reads:

/var/log/samba/log.crushed dreams 2000-5-23

Comment 1 Federico Grau 2000-05-26 15:14:59 UTC
this is really the same bug as 7999

Comment 2 Erik Troan 2000-06-18 17:29:42 UTC

*** This bug has been marked as a duplicate of 7999 ***


Note You need to log in before you can comment on or make changes to this bug.