Bug 1165534 - balloon: improve error message when adding second device
Summary: balloon: improve error message when adding second device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Luiz Capitulino
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1168097
TreeView+ depends on / blocked
 
Reported: 2014-11-19 06:45 UTC by langfang
Modified: 2015-12-04 16:21 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1168097 (view as bug list)
Environment:
Last Closed: 2015-12-04 16:21:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description langfang 2014-11-19 06:45:51 UTC
Description of problem:
Improve the error info when add the second balloon device

Version-Release number of selected component (if applicable):

Host:
# uname -r
3.10.0-205.el7.x86_64
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-2.1.2-8.el7.x86_64

Guest:win1012r2

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with balloon device
..-device virtio-balloon-pci,bus=pci.0,id=balloon0..

2.Try to hotplug another balloon device
...
 { "execute": "device_add", "arguments": { "driver": "virtio-balloon-pci","id": "balloon1" } }
{"error": {"class": "GenericError", "desc": "Adding balloon handler failed"}}
..

3.

Actual results:

The error info is hard to diagnose 
.
Expected results:
{"error": {"class": "GenericError", "desc": "Adding balloon handler failed,another balloon device already registered"}}

Additional info:
Use HMP, will see
(qemu) device_add virtio-balloon-pci,id=balloon2
Another balloon device already registered
Adding balloon handler failed
Device initialization failed.
Device 'virtio-balloon-pci' could not be initialized

Comment 2 Luiz Capitulino 2014-11-19 20:30:01 UTC
Yeah, we can improve the error message. But a second balloon device is not supported, so this is really minor. Moving to RHEL7.2.

Comment 5 Luiz Capitulino 2015-03-31 17:40:29 UTC
Fix posted upstream:

http://lists.nongnu.org/archive/html/qemu-devel/2015-03/msg06208.html

Comment 6 Miroslav Rezanina 2015-05-27 09:52:41 UTC
Fix included in qemu-kvm-rhev-2.3.0-2.el7

Comment 8 Lin Chen 2015-06-23 07:32:21 UTC
reproduce:
host kernel:3.10.0-267.el7.x86_64
host qemu:  qemu-kvm-rhev-2.1.2-21.el7.x86_64

QE retested this bug on the above environment,then got the same result.
So, the bug is reproduced on the above environment.


verify:
host kernel:3.10.0-267.el7.x86_64
host qemu:  qemu-kvm-rhev-2.3.0-4.el7.x86_64

QE retested this bug on the above environment. Got explicitly error info:{"error": {"class": "GenericError", "desc": "Only one balloon device is supported"}}
So, the bug fixed.

Comment 9 huiqingding 2015-06-24 03:43:29 UTC
Based on Comment 8, set this bug to VERIFIED.

Best regards,
Huiqing

Comment 11 errata-xmlrpc 2015-12-04 16:21:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.