Bug 1165555 - Request to retire perl-ZMQ-LibZMQ2
Summary: Request to retire perl-ZMQ-LibZMQ2
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-ZMQ-LibZMQ2
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1424052 (view as bug list)
Depends On:
Blocks: 1045884 F26FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-11-19 08:06 UTC by Thomas Spura
Modified: 2017-03-29 17:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1165554
Environment:
Last Closed: 2017-03-29 17:19:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Spura 2014-11-19 08:06:09 UTC
+++ This bug was initially created as a clone of Bug #1165554 and adjusted to match perl-ZMQ-LibZMQ2 +++

I'd like to retire zeromq2 once all packages that depend on it have been ported to zeromq-4.

Would it be possible to retire this package and add a perl-ZMQ-LibZMQ4 package, if needed? Maybe it is also possible to just use the perl-ZMQ-LibZMQ (which should always be build against the latest version of zeromq)?


Current dependencies of this packages are:
repoquery --disablerepo \* --enablerepo rawhide --repoid=rawhide --whatrequires perl-ZMQ-LibZMQ2
[empty]

-> None found.

Comment 1 Jaroslav Reznik 2015-03-03 16:31:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Fedora End Of Life 2016-07-19 12:25:37 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 3 Fedora End Of Life 2016-07-20 00:05:15 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 4 Thomas Spura 2016-11-13 10:43:40 UTC
I plan to retire zeromq2 now next week, see:
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/6LNOPHWFIMBMPR62COKIMW7YG2RZFMQT/

Comment 5 Petr Pisar 2016-12-23 10:10:17 UTC
Any progress? Please see <https://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life> for how to retire a package.

Comment 6 Petr Pisar 2017-01-20 13:58:35 UTC
If you are too busy, you can orphan the package and then I could adopt it and retire it in turn.

Comment 7 Petr Pisar 2017-02-20 07:55:58 UTC
*** Bug 1424052 has been marked as a duplicate of this bug. ***

Comment 8 Petr Pisar 2017-03-20 10:50:11 UTC
Retired in Fedora ≥ 26. Waiting on blocking in Koji.

Comment 9 Petr Pisar 2017-03-29 17:19:37 UTC
Blocked.


Note You need to log in before you can comment on or make changes to this bug.