Bug 1165596 - 69-dm-lvm-metad.rules calls systemd-run
Summary: 69-dm-lvm-metad.rules calls systemd-run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.6
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: 6.7
Assignee: Peter Rajnoha
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1152563 rhev35rcblocker 1164853 1166174
TreeView+ depends on / blocked
 
Reported: 2014-11-19 10:15 UTC by Marko Karg
Modified: 2018-12-09 19:12 UTC (History)
18 users (show)

Fixed In Version: lvm2-2.02.117-1.el6
Doc Type: Bug Fix
Doc Text:
Do not document, already released via ZStream
Clone Of:
: 1166174 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:37:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1411 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2015-07-20 18:06:52 UTC

Description Marko Karg 2014-11-19 10:15:25 UTC
Description of problem:

69-dm-lvm-metad.rules has a line (92) that reads

ACTION!="remove", ENV{LVM_PV_GONE}=="1", RUN+="/bin/systemd-run $env{LVM_SBIN_PATH}/lvm pvscan --cache $major:$minor", GOTO="lvm_end"

Since RHEL 6.6 does not have systemd this will never work.

Version-Release number of selected component (if applicable):

lvm2-2.02.111-2.el6.x86_64

How reproducible:

always

Steps to Reproduce:

1. add fcoe block devices that contain PV, VG, LV

Actual results:

No automatical activation of LVM on those block devices.

Expected results:

Automatical activation of all available PV, VGs and LVs

Additional info:

Comment 2 Peter Rajnoha 2014-11-19 10:36:37 UTC
(In reply to Marko Karg from comment #0)
> Description of problem:
> 
> 69-dm-lvm-metad.rules has a line (92) that reads
> 
> ACTION!="remove", ENV{LVM_PV_GONE}=="1", RUN+="/bin/systemd-run
> $env{LVM_SBIN_PATH}/lvm pvscan --cache $major:$minor", GOTO="lvm_end"
> 

That should have been "pvscan --background ..." for RHEL6! It's configuration error - we made the "--enable-udev-systemd-background-jobs" default, however, we don't have master switch to disable systemd - we need one - either automatic or a new configure option.

Comment 6 Peter Rajnoha 2014-11-19 12:51:30 UTC
Configure now checks for proper systemd environment and disables these specific code/rules if systemd is not available:

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=74ed1ba9f99aaf16906d53c28ad604eaa7a21419

Comment 12 Peter Rajnoha 2014-11-20 15:11:12 UTC
The fix will be delivered to 6.7 as part of the lvm2 rebase. The 6.6 is fixed via z-stream (2.02.111-2.el6_6.1).

Comment 15 Nenad Peric 2015-04-13 17:52:37 UTC
Line 92 now reads a proper:

pvscan --background --cache ...etc.

systemd is not mentioned anywhere. 

Marking this as verified with:

lvm2-2.02.118-1.el6.x86_64

Comment 16 errata-xmlrpc 2015-07-22 07:37:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1411.html


Note You need to log in before you can comment on or make changes to this bug.