Bug 116563 - grub segfaults when running "setup"
grub segfaults when running "setup"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-23 04:18 EST by František Dvořák
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 19:09:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (1.65 KB, text/plain)
2004-02-23 04:21 EST, František Dvořák
no flags Details

  None (edit)
Description František Dvořák 2004-02-23 04:18:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When I run /sbin/grub, then type 'root (hd0,1)' and 'setup (hd0)',
grub segfaults.

Note, I had the same problems also with grub in FC1 (grub-0.93-7).


Version-Release number of selected component (if applicable):
grub-0.94-2

How reproducible:
Always

Steps to Reproduce:
1. /sbin/grub
2. root (hd0,1)
3. setup --prefix=/usr/share/grub/i386-redhat (hd0)

Actual Results:  SIGSEGV

Expected Results:  grub correctly installed in MBR

Additional info:

My system is FC1 with kernel 2.6.2-1.87.
Comment 1 František Dvořák 2004-02-23 04:21:21 EST
Created attachment 97940 [details]
backtrace

Attached is backtrace of the crash (with installed debuginfo).
Comment 2 Jeremy Katz 2004-03-04 18:23:59 EST
This works for me here... can you grab the first meg or so of your
disk and attach?  Also, trying to install lilo and then reinstalling
grub might work around it.
Comment 3 Jeremy Katz 2004-06-21 19:09:27 EDT
Closing due to lack of activity.  Please reopen if you have further
information to add about the problem.

Note You need to log in before you can comment on or make changes to this bug.