Bug 116565 - ltrace /bin/true does not list library calls
ltrace /bin/true does not list library calls
Status: CLOSED DUPLICATE of bug 115299
Product: Fedora
Classification: Fedora
Component: ltrace (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 04:20 EST by Timo Lindfors
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timo Lindfors 2004-02-23 04:20:40 EST
Description of problem:
ltrace for some reason fails to list library calls.

Version-Release number of selected component (if applicable):
ltrace 0.3.29
linux 2.6.3-1.97

How reproducible:
Always.

Steps to Reproduce:
1. ltrace /bin/true
  
Actual results:
$ ltrace /bin/true
+++ exited (status 0) +++
$

Expected results:
$ ltrace /bin/true
__libc_start_main(0x08048ab4, 1, 0xbffff794, 0x0804876c, 0x080496d0
<unfinished ...>
__register_frame_info(0x0804ad04, 0x0804ae48, 0xbffff738, 0x40046f18,
0x40132e48) = 0x080487c4
setlocale(6, "")                                  =
"LC_CTYPE=fi_FI;LC_NUMERIC=C;LC_T"...
bindtextdomain("sh-utils", "/usr/share/locale")   = "/usr/share/locale"
textdomain("sh-utils")                            = "sh-utils"
__cxa_atexit(0x08048c64, 0, 0, 0x0804966c, 1)     = 0
exit(0 <unfinished ...>
ferror(0x40130200)                                = 0
__fpending(0x40130200, 0x400135cc, 0xbffff794, 0x4003f3fe, 0x40132e48)
= 0
__deregister_frame_info(0x0804ad04, 0x400135cc, 0x400137bc, 0x40013d50,
1) = 0
+++ exited (status 0) +++
$

Additional info:
Copying an ltrace 0.3.26 binary from a debian box produces the same
(incorrect) behavior so the bug probably isn't in ltrace. I do not
have root access to the box so I can't experiment with other kernel
versions.
Comment 1 Jakub Jelinek 2004-04-21 17:34:51 EDT

*** This bug has been marked as a duplicate of 115299 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.