Bug 1165676 - gvfsd-gphoto2 crashes when iPhone is connected
Summary: gvfsd-gphoto2 crashes when iPhone is connected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-19 13:29 UTC by Matthias Schroder
Modified: 2019-07-11 08:22 UTC (History)
6 users (show)

Fixed In Version: gvfs-1.4.3-22.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:44:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Window appearing when iPhone attached (19.69 KB, image/png)
2014-12-16 17:19 UTC, Matthias Schroder
no flags Details
Import Photos window (26.10 KB, image/png)
2014-12-16 17:22 UTC, Matthias Schroder
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1428 normal SHIPPED_LIVE gvfs bug fix update 2015-07-20 18:06:14 UTC

Description Matthias Schroder 2014-11-19 13:29:09 UTC
Description of problem: gvfsd-gphoto2 crashes when iPhone is connected


Version-Release number of selected component (if applicable): 1.4.3-18.el6


How reproducible: 100%


Steps to Reproduce:
1. connect iPhone
2.
3.

Actual results: gvfsd-gphoto2 crashes 


Expected results: gvfsd-gphoto2 does not crash


Additional info:

Comment 3 Ondrej Holy 2014-11-25 14:59:45 UTC
Hey, thanks for your bug report. Could you provide backtrace for gvfsd-gphoto2?

It could be solved by upstream patch to use afc instead of gphoto2 (it has same/more functionality):
https://bugzilla.gnome.org/show_bug.cgi?id=591009

Comment 4 Matthias Schroder 2014-12-03 17:24:00 UTC
Hi,

here is the backtrace:

#0  ensure_ignore_prefix (backend=0x22df010 [GVfsBackendGphoto2], job=0x22e0800, mount_spec=<value optimized out>, mount_source=<value optimized out>, 
    is_automount=<value optimized out>) at gvfsbackendgphoto2.c:1460
#1  do_mount (backend=0x22df010 [GVfsBackendGphoto2], job=0x22e0800, mount_spec=<value optimized out>, mount_source=<value optimized out>, 
    is_automount=<value optimized out>) at gvfsbackendgphoto2.c:1674
#2  0x00000000004131c2 in g_vfs_job_run (job=0x22e0800 [GVfsJobMount]) at gvfsjob.c:198
#3  0x00000039e7a6c2ab in g_thread_pool_thread_proxy (data=<value optimized out>) at gthreadpool.c:319
#4  0x00000039e7a6a374 in g_thread_create_proxy (data=0x22e1090) at gthread.c:1955
#5  0x00000039e6a079d1 in start_thread (arg=0x7ff1ca6db700) at pthread_create.c:301
#6  0x00000039e62e89dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Sorry for the late reply, I was out of the office.

Best regards,

Matthias

Comment 5 Ondrej Holy 2014-12-04 09:15:31 UTC
Thanks for your backtrace.

According the backtrace it seems the crash could be fixed by upstream commit:
https://git.gnome.org/browse/gvfs/commit/daemon/gvfsbackendgphoto2.c?id=3c1b401670c7fbdf7ad8f3034b3d508ae719d6d3

Comment 6 Martin Schuppert 2014-12-05 08:51:19 UTC
Yes, using a gvfs package with the mentioned fix do improve the situation. Matthias don't get a crash any more, but a window asks to select a tool to download pictures. Loading pictures is not possible, but that probably is another issue.

Comment 7 Ondrej Holy 2014-12-16 16:59:38 UTC
Thanks for testing. This is probably different issue, but I'm not sure what is it, could you attach screenshot?

Comment 8 Matthias Schroder 2014-12-16 17:19:31 UTC
Created attachment 969673 [details]
Window appearing when iPhone attached

Comment 9 Matthias Schroder 2014-12-16 17:22:42 UTC
Created attachment 969674 [details]
Import Photos window

The window I get when starting gThumb Image Viewer(?) with iPhone attached.

Comment 10 Matthias Schroder 2014-12-16 17:28:22 UTC
Hi Ondrej,

I have attached the two windows I get when I connect my iPhone. I first get the window with title "iPhone" ("You have just inserted..."). When I click on "OK", I get the window with the title "Import Photos". In that window I can select and de-select options, but the 'Import ' button does not do anything. Note the error message in the "Import Photos" window.

I must admit I have never ever used this, so I have no idea how this is supposed to work.

Hope this helps,

Matthias

Comment 11 Ondrej Holy 2014-12-17 09:03:36 UTC
Hey Matthias, thanks for the info. This is gthumb issue, because it is using own ptp implementation for importing images which is colliding with gvfs. As a workaround, you have to unmount gvfs mount first, see:
http://gphoto.sourceforge.net/doc/manual/FAQ.html#FAQ-already-in-use

This is already fixed in newer gthumb versions, see:
https://mail.gnome.org/archives/gthumb-list/2010-July/msg00025.html

Please file a new bug report against gthumb if it is important for you.

Comment 12 Matthias Schroder 2014-12-17 09:07:21 UTC
Hi Ondrej,

thanks a lot for the hints conecerning gthumb, highly appreciated. I agree that this is another issue, and the crashes that where the issue of this case have definitely been solved.

Cheers,

Matthias

Comment 17 errata-xmlrpc 2015-07-22 07:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1428.html


Note You need to log in before you can comment on or make changes to this bug.