Bug 116570 - Missing dependency in the vte-devel sub-package
Missing dependency in the vte-devel sub-package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-23 06:17 EST by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 02:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2004-02-23 06:17:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Epiphany/1.0.7

Description of problem:
The vte-devel package does not pull-in the required ncurses-devel
package when it is installed.

Version-Release number of selected component (if applicable):
vte-devel-0.11.10-4

How reproducible:
Always

Steps to Reproduce:
1. Install a minimal system
2. Install vte-devel and all its dependencies
3. Try to recompile an application against vte-devel
    

Actual Results:  /usr/bin/ld: cannot find -lncurses
collect2: ld returned 1 exit status

Expected Results:  The applications requiring vte-devel should be able
to recompile cleanly against it.

Additional info:

Here are the relevant vte pkgconfig lines :

Requires: xft >= 2.0 glib-2.0 gobject-2.0 gtk+-2.0 >= 2.2 fontconfig
pangoxft >= 1.1.0 pangox
Libs: -L${libdir} -lvte -lfreetype -lz -lncurses -L/usr/X11R6/lib 
-lSM -lICE  -lX11   -lm

In the vte-devel package, there is also an explicit gtk2-devel
dependency, which seems to pull in all the rest correctly (glib-devel,
freetype-devel, zlib-devel, XFree86-devel...).

The solution to this problem would be to add an explicit "Requires:
ncurses-devel" to the vte-devel sub-package.
Comment 1 Matthias Saou 2004-07-22 14:14:20 EDT
CC'ing Nalin, as he seem to be the only one to have modified this
package in the past year, and adding "EasyFix" keyword, as it's just a
matter of replacing :

Requires: %{name} = %{version}-%{release}, gtk2-devel

With :

Requires: %{name} = %{version}-%{release}, gtk2-devel, ncurses-devel

I've just checked, and in 0.11.10-5.1 in FC devel, the dependency is
still missing.
Comment 2 Ray Strode [halfline] 2004-07-22 14:33:22 EDT
This should be fixed in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.