Bug 1165856 - CVE-2014-7850 freeipa: XSS flaw can be used to escalate privileges [fedora-all]
Summary: CVE-2014-7850 freeipa: XSS flaw can be used to escalate privileges [fedora-all]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: 21
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException RejectedBlocker
Depends On:
Blocks: F21FinalFreezeException CVE-2014-7850
TreeView+ depends on / blocked
 
Reported: 2014-11-19 21:21 UTC by Vincent Danen
Modified: 2014-11-25 03:06 UTC (History)
11 users (show)

Fixed In Version: freeipa-4.1.1-2.fc21
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-25 03:06:49 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Vincent Danen 2014-11-19 21:21:25 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When submitting as an update, use the fedpkg template provided in the next
comment(s).  This will include the bug IDs of this tracking bug as well as
the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
fedpkg commit message.

NOTE: this issue affects multiple supported versions of Fedora. While only
one tracking bug has been filed, please correct all affected versions at
the same time.  If you need to fix the versions independent of each other,
you may clone this bug as appropriate.

[bug automatically created by: add-tracking-bugs]

Comment 1 Vincent Danen 2014-11-19 21:21:31 UTC
Use the following template to for the 'fedpkg update' request to submit an
update for this issue as it contains the top-level parent bug(s) as well as
this tracking bug.  This will ensure that all associated bugs get updated
when new packages are pushed to stable.

=====

# bugfix, security, enhancement, newpackage (required)
type=security

# testing, stable
request=testing

# Bug numbers: 1234,9876
bugs=1165280,1165856

# Description of your update
notes=Security fix for CVE-2014-7850

# Enable request automation based on the stable/unstable karma thresholds
autokarma=True
stable_karma=3
unstable_karma=-3

# Automatically close bugs when this marked as stable
close_bugs=True

# Suggest that users restart after update
suggest_reboot=False

======

Additionally, you may opt to use the bodhi update submission link instead:

https://admin.fedoraproject.org/updates/new/?type_=security&bugs=1165280,1165856

Comment 2 Fedora Blocker Bugs Application 2014-11-19 22:10:47 UTC
Proposed as a Blocker for 21-final by Fedora user simo using the blocker tracking app because:

 A XSS Security issue that may allow a user to elevate privileges has been found. We'd like to get it fixed in the GA images.

Comment 3 Martin Kosek 2014-11-20 08:52:38 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4742

Comment 5 Simo Sorce 2014-11-20 20:08:38 UTC
Fix fedora version, this one affects Fedora 21

Comment 6 Stephen Gallagher 2014-11-20 20:33:39 UTC
+1 Blocker. This is a serious security issue that affects a release-blocking feature.

Comment 7 Fedora Update System 2014-11-21 13:55:42 UTC
freeipa-4.1.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/freeipa-4.1.1-2.fc21

Comment 8 Fedora Update System 2014-11-22 20:21:28 UTC
Package freeipa-4.1.1-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeipa-4.1.1-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15601/freeipa-4.1.1-2.fc21
then log in and leave karma (feedback).

Comment 9 Adam Williamson 2014-11-24 18:03:17 UTC
Discussed at 2014-11-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-24/f21-blocker-review.2014-11-24-17.01.log.txt . The security criterion only covers issues with an impact of 'important' or higher, and this is only 'moderate':

https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Security_bugs

"The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update (e.g. issues during installation)."

so it's rejected as a blocker, but it's accepted as a freeze exception issue - obviously a good idea to include the fix at this point.

Comment 10 Fedora Update System 2014-11-25 03:06:49 UTC
freeipa-4.1.1-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.