Bug 116589 - Squid icons directory is wrong: squid would not start
Squid icons directory is wrong: squid would not start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-23 10:36 EST by Neal Becker
Modified: 2014-08-31 19:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.5.STABLE5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 17:02:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2004-02-23 10:36:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
/sbin/service squid start
init_cache_dir /var/spool/squid... /etc/init.d/squid: line 162: 21056 Aborted                 $SQUID -z -F -D 2>/dev/null
Starting squid: /etc/init.d/squid: line 162: 21057 Aborted                 $SQUID $SQUID_OPTS 2>/dev/null
 [60G[ [0;31mFAILED [0;39m] 

Also:

man squid brings up wrong manpage!

Version-Release number of selected component (if applicable):
squid-2.5.STABLE4-3

How reproducible:
Always

Steps to Reproduce:
1./sbin/service squid start
2.
3.
    

Additional info:
Comment 1 Alexandre Oliva 2004-02-24 05:57:31 EST
ln -s . /usr/share/squid/squid works around the bug.  The problem is
that it looks for icons in /usr/share/squid/squid/icons, and bails out
if it can't find them there.
Comment 2 daniel 2004-02-26 05:21:26 EST
Since the host anme is not fullqualified the Above first bug will 
open always.Give a fully Qualified domain name to the host and start 
ur squid

Comment 3 Aleksey Nogin 2004-02-28 17:36:05 EST
I see this too. As mentioned in comment #1, the problem is that the
squid icons directory is wrong. The actual directory is 
/usr/share/squid/icons/ while squid is compiled with
/usr/share/squid/squid/icons/
Comment 4 Aleksey Nogin 2004-03-04 16:45:34 EST
This is fixed and WFM in squid-2.5.STABLE5-1.

Note You need to log in before you can comment on or make changes to this bug.