Bug 11659 - XDMCP request hangs
Summary: XDMCP request hangs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-25 14:30 UTC by ted
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 16:37:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ted 2000-05-25 14:30:52 UTC
Hello!

I use my machine as a X-Terminal to access more powerful UNIX machines on
my network. When I moved from RH6.1 to RH6.2 I have had the bad surprise to
discover that this does not work anymore.

I changed inittab (level 3 to 5 + the following two last lines:
# Run xdm in runlevel 5
# xdm is now a separate service
x1:5:respawn:/etc/X11/prefdm -nodaemon
x2:5:respawn:/usr/X11R6/bin/X -indirect lorient.ffa.se

I changed Xservers by commenting the last line:
#:0 local /usr/X11R6/bin/X

and I changed Xaccess:
< *					#any host can get a login window
---
> # *					#any host can get a login window

Unfortunately, this does not work. XDMCP hangs and does not list the
machine on the network not add my machine to the existing list.

What did I do wrong?...

Thanks in advance

		Daniel

Comment 1 Preston Brown 2000-05-30 16:37:59 UTC
you need to change the Xaccess file on the remote machine, not the local one.
If the remote machine is using gdm, you'll need to edit the gdm configuration,
not the Xaccess file (only used by kdm/xdm).

Comment 2 ted 2000-05-30 17:04:59 UTC
Hi!

Actually my machine is listed on the net now. The problem is that I cannot get a
window on my own (the local) machine listing all the machines of the net
allowing me to connect to whatever machine I want.

Daniel


Note You need to log in before you can comment on or make changes to this bug.