Bug 1165938 - Fix regression test spurious failures
Summary: Fix regression test spurious failures
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1163543
Blocks: glusterfs-3.6.3
TreeView+ depends on / blocked
 
Reported: 2014-11-20 04:44 UTC by Atin Mukherjee
Modified: 2016-02-04 15:20 UTC (History)
4 users (show)

Fixed In Version: glusterfs-v3.6.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1163543
Environment:
Last Closed: 2016-02-04 15:05:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2014-11-20 04:44:48 UTC
+++ This bug was initially created as a clone of Bug #1163543 +++

Description of problem:
This umbrella BZ can be used to fix the spurious failures.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-11-20 06:57:02 UTC
REVIEW: http://review.gluster.org/9148 (tests: spurious failure fix for quota-anon-fd-nfs.t) posted (#1) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2014-11-20 07:02:42 UTC
REVIEW: http://review.gluster.org/9149 (tests: spurious failure fix in mgmt_v3_locks.t) posted (#1) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Anand Avati 2014-11-20 07:08:43 UTC
REVIEW: http://review.gluster.org/8997 (Regression test portability: quota-anon-fd-nfs.t) posted (#3) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Anand Avati 2014-11-21 05:16:36 UTC
REVIEW: http://review.gluster.org/9149 (tests: spurious failure fix in mgmt_v3_locks.t) posted (#2) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Anand Avati 2014-11-21 07:16:43 UTC
REVIEW: http://review.gluster.org/9148 (tests: spurious failures fix for quota-anon-fd-nfs.t) posted (#3) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Anand Avati 2014-11-21 07:16:46 UTC
REVIEW: http://review.gluster.org/8997 (tests: regression test portability - quota-anon-fd-nfs.t) posted (#4) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Kiran 2014-11-24 08:50:56 UTC
I have "Couldn't find remote ref" issue.

[root@fractal-c92e glusterfs]# git branch
  master
* release-3.6

[root@fractal-c92e glusterfs]# git fetch git://review.gluster.org/glusterfs refs/changes/97/8997/4 && git checkout FETCH_HEAD
fatal: Couldn't find remote ref refs/changes/97/8997/4

Comment 8 Anand Avati 2014-11-30 07:29:31 UTC
COMMIT: http://review.gluster.org/9149 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 358ce36fc22b74236eef67f556095665bf216916
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Nov 13 06:59:41 2014 +0530

    tests: spurious failure fix in mgmt_v3_locks.t
    
    Change-Id: I7c4599648b5d47d93a447e58c063fab21e8f9ef7
    BUG: 1165938
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/9114
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/9149
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 9 Anand Avati 2014-12-04 17:46:53 UTC
REVIEW: http://review.gluster.org/9148 (tests: spurious failures fix for quota-anon-fd-nfs.t) posted (#4) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 10 Anand Avati 2014-12-04 17:46:56 UTC
REVIEW: http://review.gluster.org/8997 (tests: regression test portability - quota-anon-fd-nfs.t) posted (#5) for review on release-3.6 by Atin Mukherjee (amukherj@redhat.com)

Comment 11 Anand Avati 2014-12-10 06:19:43 UTC
COMMIT: http://review.gluster.org/8997 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 3e2c08d3ea6b90345e626f05dc2f0f77be039188
Author: Emmanuel Dreyfus <manu@netbsd.org>
Date:   Fri Oct 24 17:10:15 2014 +0200

    tests: regression test portability - quota-anon-fd-nfs.t
    
    Fix portability problems in quota-anon-fd-nfs.t
    - Use mount_nfs wrapper and include nfs.rc to get it defined.
    - umount NFS before cleanup to avvoid deadlocks.
    - umount -l is Linux-specific, use umount -f on BSD.
    - wait for 1s for portmap registration before mouting NFS.
    - mount from $H0 instead of localhost: the later fails on NetBSD.
    - Test quota without filling GB of data, 20MB is enough and it
      will be gentle with smaller setups.
    - wait for write behind to complete before testing quota overflow
    
    BUG: 1165938
    Change-Id: I097d5faed2fa7b6438aaa56def85172f23bbe7dc
    Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org>
    Reviewed-on: http://review.gluster.org/8969
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Kiran Patil <kiran@fractalio.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/8997
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 12 Anand Avati 2014-12-10 18:10:15 UTC
COMMIT: http://review.gluster.org/9148 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit a86be91a2ae01fc79539dece6a67d1845badba35
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Nov 13 07:03:54 2014 +0530

    tests: spurious failures fix for quota-anon-fd-nfs.t
    
    Change-Id: I4f7ee68c514d8d322e25cf74167f288a8b6f8164
    BUG: 1165938
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/9108
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9148
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 13 Anand Avati 2014-12-19 07:20:26 UTC
REVIEW: http://review.gluster.org/9308 (tests: spurious failure fix for bug-1164613.t) posted (#1) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 14 Anand Avati 2014-12-19 08:59:46 UTC
REVIEW: http://review.gluster.org/9308 (tests: spurious failure fix for bug-1164613.t.) posted (#2) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 15 Anand Avati 2015-02-24 06:14:28 UTC
REVIEW: http://review.gluster.org/9728 (Fix for test uss.t and bug-1167580-set-proper-uid-and-gid-during-nfs-access.t) posted (#3) for review on release-3.6 by Justin Clift (justin@gluster.org)

Comment 16 Anand Avati 2015-02-24 06:47:00 UTC
COMMIT: http://review.gluster.org/9728 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit a46325cd37806a8e9d1abbb121d4e854799042ae
Author: vmallika <vmallika@redhat.com>
Date:   Thu Feb 19 17:54:03 2015 +0530

    Fix for test uss.t and bug-1167580-set-proper-uid-and-gid-during-nfs-access.t
    
    testcase uss.t and
    bug-1167580-set-proper-uid-and-gid-during-nfs-access.t
    uses below method to generate random string
    cat /dev/urandom | tr -dc 'a-zA-Z' | fold -w 8 | head -n 1
    
    Doing a cat on /dev/urandom can consume more CPU usage.
    
    Change to:
    uuidgen | tr -dc 'a-zA-Z' | head -c 8
    
    Backport of http://review.gluster.org/#/c/9703/
    
    Change-Id: Id08ec47e39b12f956e266d30cc5327b5b70c2fb0
    Reviewed-on: http://review.gluster.org/9728
    BUG: 1165938
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-by: Justin Clift <justin@gluster.org>
    Tested-by: Justin Clift <justin@gluster.org>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 17 Anand Avati 2015-03-04 13:56:01 UTC
REVIEW: http://review.gluster.org/9798 (tests: Spurious failure in bug-1117851.t) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 18 Anand Avati 2015-03-04 13:59:00 UTC
REVIEW: http://review.gluster.org/9798 (tests: Spurious failure in bug-1117851.t) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 19 Anand Avati 2015-03-10 11:55:42 UTC
REVIEW: http://review.gluster.org/9850 (tests : Fix spurious failure in uss.t) posted (#1) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 20 Anand Avati 2015-03-11 05:08:09 UTC
REVIEW: http://review.gluster.org/9850 (tests : Fix spurious failure in uss.t) posted (#2) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 21 Anand Avati 2015-03-13 05:16:24 UTC
REVIEW: http://review.gluster.org/9850 (tests : Fix spurious failure in uss.t.) posted (#3) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 22 Anand Avati 2015-03-13 07:36:41 UTC
COMMIT: http://review.gluster.org/9850 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 263e23c52fb66b218d85254dcb2b54ab51832ba4
Author: Sachin Pandit <spandit@redhat.com>
Date:   Tue Mar 10 10:19:51 2015 +0530

    tests : Fix spurious failure in uss.t.
    
    Problem : When we change the USS working directory, the
    change is reflected in the volfile. So whenever snapd
    tries to fetch the current USS directory there is some delay
    and because of that if any lookup operation comes at that time
    on new USS directory there might be chances of failure.
    
    Solution : Check whether the directory exits in "EXPECT_WITHIN"
    as we can check few time if change is getting reflected.
    
    
    ==================================================
    ok 84
    ok 85
    ok 86
    ok 87
    ls: cannot access /mnt/glusterfs/0/.history: No such file or directory
    not ok 88
    FAILED COMMAND: ls /mnt/glusterfs/0/.history
    ok 89
    ok 90
    ok 91
    ok 92
    ok 93
    ===================================================
    
    Change-Id: Id739a929198829d9980ee4af44248c9e426caabe
    BUG: 1165938
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/9850
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 23 Anand Avati 2015-03-18 09:33:58 UTC
REVIEW: http://review.gluster.org/9925 (syncop: spurious failure ./tests/basic/quota-nfs.t) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 24 Anand Avati 2015-03-18 10:02:10 UTC
REVIEW: http://review.gluster.org/9925 (syncop: spurious failure ./tests/basic/quota-nfs.t) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 25 Anand Avati 2015-03-18 10:09:15 UTC
REVIEW: http://review.gluster.org/9925 (syncop: spurious failure ./tests/basic/quota-nfs.t) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 26 Anand Avati 2015-03-18 12:10:14 UTC
REVIEW: http://review.gluster.org/9925 (debug inodelk unlock errors) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 27 Anand Avati 2015-04-15 06:57:15 UTC
REVIEW: http://review.gluster.org/10243 (quota : Fix smoke test failure.) posted (#1) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 28 Anand Avati 2015-04-16 06:30:31 UTC
COMMIT: http://review.gluster.org/10243 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit 09dd086e776aa4d1c2ce3abe0e3b74b298372141
Author: Sachin Pandit <spandit@redhat.com>
Date:   Tue Apr 14 04:18:56 2015 +0530

    quota : Fix smoke test failure.
    
    Functions check_ancestory_2 and quota_build_ancestry related
    to quota feature was not declared in the header file.
    This patch fixes the failure caused because of the mentioned
    reason.
    
    Change-Id: I967ee8ea943e2e7a54718e21245d1f63eb4d70e9
    BUG: 1165938
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/10243
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>

Comment 29 Anand Avati 2015-04-16 06:51:29 UTC
REVIEW: http://review.gluster.org/10263 (Test : Patch to check if there are any failure.) posted (#1) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 30 Anand Avati 2015-04-17 04:42:46 UTC
REVIEW: http://review.gluster.org/10263 (Test : Patch to check if there are any failure) posted (#2) for review on release-3.6 by Sachin Pandit (spandit@redhat.com)

Comment 31 Kaushal 2016-02-04 15:05:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.2, please open a new bug report.

glusterfs-v3.6.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978top
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 32 Kaushal 2016-02-04 15:08:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.2, please open a new bug report.

glusterfs-v3.6.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2015/01/glusterfs-3-6-2-ga-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 33 Kaushal 2016-02-04 15:20:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.3, please open a new bug report.

glusterfs-v3.6.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2015-April/021669.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.