Bug 1165990 - cannot open guest console after input incorrect passwd for spice several times quickly
Summary: cannot open guest console after input incorrect passwd for spice several time...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-20 08:25 UTC by CongDong
Modified: 2015-11-19 05:22 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.2.0-1-el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:22:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Description CongDong 2014-11-20 08:25:07 UTC
Description of problem:
Set a password for a spice guest, if input a wrong password,
and try to input again, repeat the operation quickly,
after several time, virt-manager console will change black and 
cannot connect the guest.

Version-Release number of selected component (if applicable):
virt-manager-1.1.0-7.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install a spice guest and set the spice password with "aabb";
2. start the guest and try to open it with virt-manager
# virsh start $vm
# virt-manager
double click on the guest item
3. the password dialog will come out, now input the wrong password like "a",
and confirm by click "Enter" quickly
4. the password dialog will come out again, repeat step3 quickly about 10 times
(not easy to reproduce, maybe 20 times).

Actual results:
After several times, the console will be black.

Expected results:
The password dialog should show again until the password is correct.

Additional info:

Comment 2 Giuseppe Scrivano 2014-11-20 09:46:11 UTC
patch proposed upstream:

https://www.redhat.com/archives/virt-tools-list/2014-November/msg00113.html

Anyway, this minor issue is not worth a backport, moving to 7.2.

Comment 6 fwu 2015-05-21 03:45:42 UTC
I can reproduce this issue with package:
virt-manager-1.1.0-12.el7.noarch

Steps are the same as description above.

Results:
When wrong password was input every time, the screen will flash black and white.
After several times, the console will be black.

Then try to verify with new build:
virt-manager-1.2.0-2.el7.noarch

Steps:
1. Install a guest with spice display server and set the spice password with "aabb";
2. start the guest and try to open it with virt-manager
# virsh start $vm
# virt-manager
double click on the guest item
3. the password dialog will come out, now input the wrong password like "a",
and confirm by click "Enter" quickly
4. the password dialog will come out again, repeat step3 quickly about 10 times.

Result:
1. After step 3, the screen will not flash.
2. After step 4, The console will not be black.

According to the result stated above, move this bug from ON_QA to VERIFIED

Comment 8 errata-xmlrpc 2015-11-19 05:22:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.