Bug 116603 - SoundBlaster AWE32 not recognised by ALSA drivers
SoundBlaster AWE32 not recognised by ALSA drivers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 13:27 EST by Pavel Polischouk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 15:03:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Polischouk 2004-02-23 13:27:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Trying to get my ageing AWE32 (non-PnP) to work. It used to work
perfectly with OSS drivers, option strings from my old modules.conf:

options sb dma16=5 io=0x220 mpu_io=0x330 dma=0 irq=5
options opl3 io=0x388

kernel-2.6.1-1.65 doesn't build the OSS drivers, I tried to upgrade to
ALSA. Neither snd-sbawe nor snd-sb16 would load.

I tried loading with no parameters, and using the following command line:

modprobe snd-sbawe dma16=5 port=0x220 mpu_port=0x330 dma8=0 irq=5
fm_port=0x388

I can't check this behaviour on the newer kernels - they won't boot,
see bug 116490.

Version-Release number of selected component (if applicable):
kernel-2.6.1-1.65

How reproducible:
Always

Steps to Reproduce:
1. Configure the jumpers on SB AWE32 to use dma16=5 port=0x220
mpu_port=0x330 dma8=0 irq=5 fm_port=0x388
2. Try to load snd-sbawe.ko

Actual Results:  FATAL: Error inserting snd_sbawe
(/lib/modules/2.6.1-1.65/kernel/sound/isa/sb/snd-sbawe.ko): No such device

Expected Results:  Driver should load and work

Additional info:

Other relevant packages on the system:
kernel-utils-2.4-9.1.120
alsa-utils-1.0.2-2
Comment 1 Pavel Polischouk 2004-02-25 10:37:45 EST
Same with 2.6.3-1.100
Comment 2 Pavel Polischouk 2004-03-23 15:03:08 EST
this is not a bug, i should've RTFM.

Note You need to log in before you can comment on or make changes to this bug.