This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 116611 - up2date-4.3.11-2.1 crashes after package download
up2date-4.3.11-2.1 crashes after package download
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-23 14:24 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 21:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-02-23 14:24:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
up2date-4.3.11-2.1 crashes after all packages have been downloaded:

[root@deanna root]# up2date
/usr/share/rhn/up2date_client/checklist.py:139: DeprecationWarning:
integer argument expected, got float
  info  = self.get_selection_info (event.x, event.y)
/etc/security/selinux/src/policy/file_contexts/file_contexts: No such
file or directory
python: rpmio_internal.h:497: c2f: Assertion `fd && fd->magic ==
0x04463138' failed.
Abgebrochen


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run up2date
2.
3.
    

Additional info:
Comment 1 Bernd Bartmann 2004-02-25 04:28:09 EST
If I don't select all available packages at once but only a small
subset I can circumvent this problem.
Comment 2 Hal Black 2004-02-29 11:40:56 EST
My install is an "install everything" (minus some i18n packages that I
manually uninstalled) and I see this too:

# up2date -u
[...]
yum-2.0.5.20040224-1.noarch ########################## Done.
zip-2.3-20.i386.rpm:        ########################## Done.
zisofs-tools-1.0.4-4.i386.r ########################## Done.
zlib-1.2.1.1-2.i386.rpm:    ########################## Done.
zlib-devel-1.2.1.1-2.i386.r ########################## Done.
zsh-4.0.9-2.i386.rpm:       ########################## Done.
zsh-html-4.0.9-2.i386.rpm:  ########################## Done.
elfutils-libelf-devel-0.94- ########################## Done.
libdv-0.101-2.i386.rpm:     ########################## Done.
openssl-0.9.7a-30.i386.rpm: ########################## Done.
python: rpmio_internal.h:497: c2f: Assertion `fd && fd->magic ==
0x04463138' failed.
Aborted
Comment 3 Adrian Likins 2004-04-07 17:05:03 EDT
This should be fixed in up2date-4.3.15 or higher (selinux fixes)
Comment 4 Jef Spaleta 2004-05-05 23:10:28 EDT
i did a test3 install on may 2nd, using up2date exclusively for updates
I havent seen a crash yet and i have done 2 rounds of updates a new
round of 34 packages today.
up2date 4.3.17 is currently installed on the system.
Im using the default test3 selinux settings.
Comment 5 Colin Charles 2004-05-06 00:34:23 EDT
I just performed a test3 install - it ships with up2date-4.3.16-1 by
default. This problem has not been seen, and up2date updated my
software just fine. up2date is currently at version 4.3.17-1. My
SELinux is default for test3 as well.

Note You need to log in before you can comment on or make changes to this bug.