Bug 116613 - Compile error - using kernel headers directly
Compile error - using kernel headers directly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 14:34 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 11:26:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-02-23 14:34:45 EST
Why is this package using kernel headers directly?

make[1]: Entering directory `/usr/src/redhat/BUILD/eject-2.0.13/po'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/src/redhat/BUILD/eject-2.0.13/po'
make[1]: Entering directory `/usr/src/redhat/BUILD/eject-2.0.13'
gcc -DPACKAGE=\"eject\" -DVERSION=\"2.0.13\" -DSTDC_HEADERS=1
-DHAVE_SYS_WAIT_H=1 -DHAVE_FCNTL_H=1 -DHAVE_SYS_IOCTL_H=1
-DHAVE_UNISTD_H=1 -DHAVE_REGCOMP=1 -DHAVE_STRDUP=1 -DHAVE_STRERROR=1 
-I. -I.   -I/usr/src/linux -I/usr/src/linux/include
-DDEFAULTDEVICE=\"cdrom\" -DGETOPTLONG  -Wall -O3 -O2 -g -pipe
-march=athlon -O2 -g -pipe -march=athlon -c eject.c
In file included from /usr/src/linux/include/linux/cdrom.h:14,
                 from eject.c:62:
/usr/src/linux/include/asm/byteorder.h:14: error: syntax error before
"__u32"
/usr/src/linux/include/asm/byteorder.h:28: error: syntax error before
"__u64"
In file included from
/usr/src/linux/include/linux/byteorder/little_endian.h:11,
                 from /usr/src/linux/include/asm/byteorder.h:57,
                 from /usr/src/linux/include/linux/cdrom.h:14,
                 from eject.c:62:
/usr/src/linux/include/linux/byteorder/swab.h:133: error: syntax error
before "__u16"
/usr/src/linux/include/linux/byteorder/swab.h:146: error: syntax error
before "__u32"
/usr/src/linux/include/linux/byteorder/swab.h:160: error: syntax error
before "__u64"
In file included from eject.c:68:
/usr/src/linux/include/scsi/scsi.h:203: error: syntax error before "u8"
/usr/src/linux/include/scsi/scsi.h:203: warning: no semicolon at end
of struct or union
/usr/src/linux/include/scsi/scsi.h:204: warning: type defaults to
`int' in declaration of `medium'
/usr/src/linux/include/scsi/scsi.h:204: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:205: error: syntax error before "_r2"
/usr/src/linux/include/scsi/scsi.h:205: warning: type defaults to
`int' in declaration of `_r2'
/usr/src/linux/include/scsi/scsi.h:205: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:206: error: syntax error before
"block_desc_length"
/usr/src/linux/include/scsi/scsi.h:206: warning: type defaults to
`int' in declaration of `block_desc_length'
/usr/src/linux/include/scsi/scsi.h:206: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:207: error: syntax error before
"density"
/usr/src/linux/include/scsi/scsi.h:207: warning: type defaults to
`int' in declaration of `density'
/usr/src/linux/include/scsi/scsi.h:207: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:208: error: syntax error before
"number_blocks_hi"
/usr/src/linux/include/scsi/scsi.h:208: warning: type defaults to
`int' in declaration of `number_blocks_hi'
/usr/src/linux/include/scsi/scsi.h:208: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:209: error: syntax error before
"number_blocks_med"
/usr/src/linux/include/scsi/scsi.h:209: warning: type defaults to
`int' in declaration of `number_blocks_med'
/usr/src/linux/include/scsi/scsi.h:209: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:210: error: syntax error before
"number_blocks_lo"
/usr/src/linux/include/scsi/scsi.h:210: warning: type defaults to
`int' in declaration of `number_blocks_lo'
/usr/src/linux/include/scsi/scsi.h:210: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:211: error: syntax error before "_r3"
/usr/src/linux/include/scsi/scsi.h:211: warning: type defaults to
`int' in declaration of `_r3'
/usr/src/linux/include/scsi/scsi.h:211: warning: data definition has
no type or storage class /usr/src/linux/include/scsi/scsi.h:212:
error: syntax error before "block_length_hi"
/usr/src/linux/include/scsi/scsi.h:212: warning: type defaults to
`int' in declaration of `block_length_hi'
/usr/src/linux/include/scsi/scsi.h:212: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:213: error: syntax error before
"block_length_med"
/usr/src/linux/include/scsi/scsi.h:213: warning: type defaults to
`int' in declaration of `block_length_med'
/usr/src/linux/include/scsi/scsi.h:213: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:214: error: syntax error before
"block_length_lo"
/usr/src/linux/include/scsi/scsi.h:214: warning: type defaults to
`int' in declaration of `block_length_lo'
/usr/src/linux/include/scsi/scsi.h:214: warning: data definition has
no type or storage class
/usr/src/linux/include/scsi/scsi.h:221: error: syntax error before "u8"
/usr/src/linux/include/scsi/scsi.h:221: warning: no semicolon at end
of struct or union
make[1]: *** [eject.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/eject-2.0.13'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.40075 (%build)
                                                                     
                                                       
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.40075 (%build)
Comment 1 Ngo Than 2004-02-23 15:54:13 EST
Hm, it does not use kernel headers directly, but glibc-kernheaders.
It looks like that your glibc-kernheaders is broken!

It can be rebuilt without any problem in fc2
Comment 2 Ivan Gyurdiev 2004-02-23 16:59:12 EST
-I/usr/src/linux -I/usr/src/linux/include

How is this not using kernel headers directly? Please explain.

glibc-kernheaders is the thing that goes in /usr/include/linux.
My kernel is the thing that goes in /usr/src/linux/include.
Furthermore, this *is* fc2. My system has been running rawhide
for as long as I can remember.




Comment 3 Ngo Than 2004-02-25 11:26:37 EST
oh sorry, i was blind here:(  it's fixed now in eject-2.0.13-5.

Note You need to log in before you can comment on or make changes to this bug.