Bug 1166187 - Chargeback throws "undefined method '[]' for nil:NilClass [configuration/form_field_changed]"
Summary: Chargeback throws "undefined method '[]' for nil:NilClass [configuration/form...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.4.0
Assignee: Aparna Karve
QA Contact: Thom Carlin
URL:
Whiteboard:
Depends On:
Blocks: 1161793 1166215
TreeView+ depends on / blocked
 
Reported: 2014-11-20 14:33 UTC by Thom Carlin
Modified: 2015-06-16 12:44 UTC (History)
4 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1166215 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:44:54 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Thom Carlin 2014-11-20 14:33:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Thom Carlin 2014-11-20 14:43:19 UTC
Let's try that again:

Description of problem:

undefined method '[]' for nil:NilClass [configuration/form_field_changed]

Version-Release number of selected component (if applicable):

5.3.1

How reproducible:

Every time

Steps to Reproduce:
1. Cloud Intelligence > Chargeback
2. (Assignments)
3. Assignments > Storage
4. Click "Check all" at bottom

Actual results:

Error

Expected results:

No error

Additional info:

/var/www/miq/vmdb/log/production.log with backtrace attached

Comment 2 Thom Carlin 2014-11-20 14:43:42 UTC
Correction: version 5.3.0

Comment 5 CFME Bot 2014-11-24 21:31:09 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/066e71ddb035170bf8a66b6396db25210ae95d63

commit 066e71ddb035170bf8a66b6396db25210ae95d63
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Fri Nov 21 11:41:58 2014 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Fri Nov 21 11:41:58 2014 -0800

    Hide the paging controls in Chargeback -> Assignments -> Storage
    
    The call to the 'cb_rates_list' method applies to the Rates accordion
    only and should not be called in explorer since that fetches the
    chargeback rates list and displays a paging control at the bottom of
    the 'Assignments' page where the paging controls are not applicable.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1166187

 vmdb/app/controllers/chargeback_controller.rb | 1 -
 1 file changed, 1 deletion(-)

Comment 6 Aziza Karol 2015-02-02 15:17:21 UTC
paging controls hidden in Chargeback -> Assignments -> Storage

upstream verified:
master.20150131061928_597806a

Comment 8 Thom Carlin 2015-03-11 17:10:26 UTC
Verified using build version: 5.4.0.0.11.20150309201930_8b6a235

Comment 10 errata-xmlrpc 2015-06-16 12:44:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.