Bug 1166227 - RFE: Extend xflock4 with proper screensaver/-locker support
Summary: RFE: Extend xflock4 with proper screensaver/-locker support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-session
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-20 15:21 UTC by Raphael Groner
Modified: 2015-06-26 20:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-26 20:39:01 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1166860 None None None Never
Xfce 8993 None None None Never
Xfce 10217 None None None Never

Internal Links: 1166860

Description Raphael Groner 2014-11-20 15:21:54 UTC
Description of problem:
Installing lxqt-panel forces xscreensaver-base that breaks my Xfce configuration with xlockmore.

Version-Release number of selected component (if applicable):
rawhide

How reproducible:
yes

Steps to Reproduce:
1. yum install lxqt-panel
2. login to xfce
3. lock screen

Actual results:
Xscreensaver is forced to be used in Xfce cause it's prioritized in xflock4.

Expected results:
Xscreensaver should not be used in Xfce as the default screen locker if it wasn't installed -before-.

Additional info:
Maybe this is a feature request for xfce4-session. CC'ing to the maintainer.

Currently, therre is only the work-around to remove lxqt-panel again.

Comment 1 Kevin Fenzi 2014-11-20 16:57:14 UTC
You should be able to go into your xfce4 session prefs and tell it not to start xscreensaver (it adds this by default, but you should be able to remove it). 

Does that do what you are trying to do?

Comment 2 Raphael Groner 2014-11-21 10:01:52 UTC
Xscreensaver is in the list of session startups but not checked to be started automatically. It's started anyhow if I click at the lock button or use xfpm with timeout, so I don't use the internal delay settings of xscreensaver configuration.

Comment 3 Kevin Fenzi 2014-11-21 17:45:32 UTC
Odd. I thought it just called xscreensaver-command -lock, which if xscreensaver isn't running, shouldn't work. :( I'll try and look more into it...

Comment 4 Raphael Groner 2014-11-21 18:05:48 UTC
In case of xflock4, we should think about an exo plugin to use xfconf to save user's preferred locker in a multi-user and multi-desktop environment.

But still, I think this is primarily a bug in the lxqt-panel package and that Requires: xscreensaver-base should be moved into some lxqt meta package or comps group.

$ sh -x xflock4
+ PATH=/bin:/usr/bin
+ export PATH
+ for lock_cmd in '"xscreensaver-command -lock"' '"gnome-screensaver-command --lock"'
+ xscreensaver-command -lock
+ for lock_cmd in '"xscreensaver-command -lock"' '"gnome-screensaver-command --lock"'
+ gnome-screensaver-command --lock
+ for lock_cmd in '"xlock -mode random"' '"slock"'
+ set -- xlock -mode random
+ command -v -- xlock
+ xset dpms force off
+ xlock -mode random
+ exit

Comment 5 Kevin Fenzi 2014-11-21 18:09:32 UTC
(In reply to Raphael Groner from comment #4)
> In case of xflock4, we should think about an exo plugin to use xfconf to
> save user's preferred locker in a multi-user and multi-desktop environment.

If by "we" you mean upstream, then I agree. ;) We should work upstream to revamp xflock4.

Comment 6 Raphael Groner 2014-11-22 10:13:54 UTC
The maintainer of xscreensaver refuses to fix a still running zombie process, see bug #1166860.

Comment 7 Raphael Groner 2014-11-22 16:23:54 UTC
Hmm, this seems to become more like a RFE for Xfce. So reassigning to xfce4-session package (and leave lxqt for its own decision to enforce xscreensaver whyever).

Upstream: http://bugzilla.xfce.org/show_bug.cgi?id=8993

Comment 8 Raphael Groner 2015-02-28 16:09:46 UTC
As far as I understand upstream discussion, this bug should go away with the official Xfce 4.12 release.

Comment 9 Martin Sourada 2015-03-05 20:27:50 UTC
Seems it didn't landed in xfce-4.12. Can we patch the package until this is solved upstream? If so I'd suggest including mate-screensaver (which is what I'm using with xfce) and dropping gnome-screensaver (), as per first patch <https://bugzilla.xfce.org/attachment.cgi?id=5088> at xfce 10217.

Comment 10 Raphael Groner 2015-03-05 20:40:23 UTC
My vote goes for xlockmore instead of either mate- or gnome-screensaver. But xscreensaver should stay the default cause commonly known to not confuse any user.

Comment 11 Raphael Groner 2015-03-26 09:53:24 UTC
(In reply to Martin Sourada from comment #9)
> Seems it didn't landed in xfce-4.12. Can we patch the package until this is
> solved upstream? 

http://git.xfce.org/xfce/xfce4-session/commit/?id=e940818853582290af21bf38d73ee26143d500ad

Please apply this long overdue upstream patch.

Comment 12 Fedora Update System 2015-03-29 13:31:20 UTC
xfce4-session-4.12.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xfce4-session-4.12.1-2.fc22

Comment 13 Kevin Fenzi 2015-03-29 13:37:58 UTC
ok, I have commited and pushed to rawhide and f22 what upstream
commited. 

Basically a xfconf key that (when set) will override all the hard coded
junk in the xflock4 script. 

You can create/set it with: 

xfconf-query -c xfce4-session -p /general/LockCommand -t string -n -s
"xscreensaver-command -lock"

etc.

Comment 14 Raphael Groner 2015-03-29 14:07:33 UTC
(In reply to Kevin Fenzi from comment #13)
…
> You can create/set it with: 
> 
> xfconf-query -c xfce4-session -p /general/LockCommand -t string -n -s
> "xscreensaver-command -lock"
> 
> etc.

Yeah, this still looks somehow like a hack. There should be a "preferred application for screen locking" setting somewhere in the GUI configuration dialogs.

Comment 15 Kevin Fenzi 2015-03-29 14:29:07 UTC
Sure, upstream is still discussing where this will go, but in the mean time those users that need this can at least have something.

Comment 16 Fedora Update System 2015-03-30 07:11:13 UTC
Package xfce4-session-4.12.1-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-session-4.12.1-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5045/xfce4-session-4.12.1-2.fc22
then log in and leave karma (feedback).

Comment 17 Raphael Groner 2015-03-30 18:58:21 UTC
(In reply to Fedora Update System from comment #12)
> xfce4-session-4.12.1-2.fc22 has been submitted as an update for Fedora 22.
> https://admin.fedoraproject.org/updates/xfce4-session-4.12.1-2.fc22

$ xfconf-query -c xfce4-session -p /general/LockCommand -t string -n -s "xlock -mode fire"

Does not work. Did you really apply the patch? xlockmore-gtk is installed here.

Comment 18 Kevin Fenzi 2015-03-30 19:14:08 UTC
Yes, it's applied in the 4.12.1-3 update, not the -2 one. 

It should update this bug again once that update goes to testing...

Comment 19 Raphael Groner 2015-03-30 19:32:08 UTC
Please test with -3:

https://admin.fedoraproject.org/updates/xfce4-session-4.12.1-3.fc22

That one looks good to me.

Comment 20 Raphael Groner 2015-06-26 20:39:01 UTC
Status: stable
Pushed: True
Date Submitted:	2015-03-29 19:23:29
Date Released: 	2015-03-31 17:04:41
Submitter: 	kevin
Karma: 	2

Please feel free to reopen this bug if you think it's not fixed.


Note You need to log in before you can comment on or make changes to this bug.