Bug 1166293 - Libgfapi symbolic version breaking Samba Fedora rawhide (22) koji builds
Summary: Libgfapi symbolic version breaking Samba Fedora rawhide (22) koji builds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1166232
Blocks: glusterfs-3.6.2
TreeView+ depends on / blocked
 
Reported: 2014-11-20 17:58 UTC by Niels de Vos
Modified: 2016-02-04 15:09 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v3.6.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1166232
Environment:
Last Closed: 2016-02-04 15:09:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2014-11-20 17:58:50 UTC
+++ This bug was initially created as a clone of Bug #1166232 +++

Description of problem:
The latest changes for libgfapi to keep  version of glusterfs-api.so to "0" is breaking Samba builds as Samba is looking for "glusterfs-api >= 4" in gluster-api.pc file. 

Refer http://koji.fedoraproject.org/koji/buildinfo?buildID=593897

Version-Release number of selected component (if applicable):

3.6.1 and later (that includes mainline) 

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

http://koji.fedoraproject.org/koji/buildinfo?buildID=593897

From: https://kojipkgs.fedoraproject.org//work/tasks/7114/8167114/build.log

hecking for glusterfs-api >= 4                                                                 : not found 
Checking for header api/glfs.h                                                                  : no 
Checking for library gfapi                                                                      : yes 
ERROR: Target 'gfapi' in directory /builddir/build/BUILD/samba-4.2.0rc2/source3 re-defined as EMPTY - was SYSLIB
error: Bad exit status from /var/tmp/rpm-tmp.j8Dm9x (%build)
    Macro %python_libdir defined but not used within scope
    Bad exit status from /var/tmp/rpm-tmp.j8Dm9x (%build)
RPM build errors:
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps  builddir/build/SPECS/samba.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mockbuild/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.7/site-packages/mockbuild/util.py", line 378, in do
    raise mockbuild.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps  builddir/build/SPECS/samba.spec']
LEAVE do --> EXCEPTION RAISED

--- Additional comment from Anand Avati on 2014-11-20 16:42:55 CET ---

REVIEW: http://review.gluster.org/9154 (pkg-config: make the version in gluster-api.pc backwards compatible) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Niels de Vos on 2014-11-20 17:33:52 CET ---

Build pushed to Fedora Rawhide:
- http://koji.fedoraproject.org/koji/buildinfo?buildID=594572

--- Additional comment from Anand Avati on 2014-11-20 18:57:29 CET ---

COMMIT: http://review.gluster.org/9154 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 6ba258d2b7d4520af95ff638e02598e4aa247ec4
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu Nov 20 16:26:36 2014 +0100

    pkg-config: make the version in gluster-api.pc backwards compatible
    
    Once we released gluster-api.pc with version=4. Since then we undid the
    library versioning and replaced it with symbol-versioning. The current
    libgfapi.so has version 0, but the symbols have the version from the
    main package at the time they were added.
    
    Because other packages (like samba) use the pkg-config version, we can
    not drop it, or decrease the version easily. The simplest solution is to
    keep the version=4 and add sub-digits for the actual package/symbol
    versions. In future, the version in gluster-api.pc will be like 4.3.x.y.
    
    Change-Id: If359c8de5b847a7e818199a7246636113837da2d
    BUG: 1166232
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9154
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 1 Anand Avati 2014-11-20 18:02:11 UTC
REVIEW: http://review.gluster.org/9169 (pkg-config: make the version in gluster-api.pc backwards compatible) posted (#1) for review on release-3.6 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2014-12-03 12:02:27 UTC
COMMIT: http://review.gluster.org/9169 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 471292ed2ef8fb50428125304b78e7348a822ccc
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu Nov 20 19:01:29 2014 +0100

    pkg-config: make the version in gluster-api.pc backwards compatible
    
    Once we released gluster-api.pc with version=4. Since then we undid the
    library versioning and replaced it with symbol-versioning. The current
    libgfapi.so has version 0, but the symbols have the version from the
    main package at the time they were added.
    
    Because other packages (like samba) use the pkg-config version, we can
    not drop it, or decrease the version easily. The simplest solution is to
    keep the version=4 and add sub-digits for the actual package/symbol
    versions. In future, the version in gluster-api.pc will be like 4.3.x.y.
    
    Cherry picked from commit 6ba258d2b7d4520af95ff638e02598e4aa247ec4:
    > Change-Id: If359c8de5b847a7e818199a7246636113837da2d
    > BUG: 1166232
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/9154
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: Ifc9777c4af0520f77557bf99d9c7a888552faff0
    BUG: 1166293
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9169
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Kaushal 2016-02-04 15:09:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.2, please open a new bug report.

glusterfs-v3.6.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2015/01/glusterfs-3-6-2-ga-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.