Bug 1166316 - Rebase mod_nss to support TLSv1.2
Summary: Rebase mod_nss to support TLSv1.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mod_nss
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Harmsen
QA Contact: Kaleem
URL:
Whiteboard:
: 1169870 (view as bug list)
Depends On:
Blocks: 1057564 1154687 1169871 1175494
TreeView+ depends on / blocked
 
Reported: 2014-11-20 19:44 UTC by Rob Crittenden
Modified: 2015-07-22 06:13 UTC (History)
8 users (show)

Fixed In Version: mod_nss-1.0.10-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The mod_nss packages have been upgraded to upstream version 1.0.10, which provides a number of bug fixes and enhancements over the previous version. Most notably, this update adds support for TLS version 1.2 to mod_nss. (BZ#1166316)
Clone Of:
Environment:
Last Closed: 2015-07-22 06:13:13 UTC


Attachments (Terms of Use)
Patch to downgrade httpd 2.4 down to httpd 2.2 (5.16 KB, patch)
2015-01-23 22:47 UTC, Matthew Harmsen
no flags Details | Diff
Patch to downgrade httpd 2.4 down to httpd 2.2 (spec file) (12.85 KB, patch)
2015-01-23 22:49 UTC, Matthew Harmsen
no flags Details | Diff
snip from automation log (14.17 KB, text/plain)
2015-04-24 15:48 UTC, Kaleem
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1284 normal SHIPPED_LIVE mod_nss bug fix and enhancement update 2015-07-20 17:48:57 UTC

Description Rob Crittenden 2014-11-20 19:44:37 UTC
Description of problem:

NSS 3.15.1+ supports TLSv1.2, mod_nss can enable it now as well. Support was added to NSS via BZ https://bugzilla.mozilla.org/show_bug.cgi?id=480514

Support for 1.2 was added upstream to mod_nss in https://bugzilla.redhat.com/show_bug.cgi?id=1119484

This package should be rebased to the upstream version to take advantage of this capability.

Comment 4 Nathan Kinder 2014-12-05 16:53:09 UTC
*** Bug 1169870 has been marked as a duplicate of this bug. ***

Comment 5 Matthew Harmsen 2014-12-16 01:31:44 UTC
Although 1169870 was marked as a duplicate of this bug, it should be noted that as a part of fixing this bug, the 'SSLv3,' string should be removed from the 'NSSProtocol SSLv3,TLSv1.0,TLSv1.1' line in the default 'nss.conf' file.

Comment 6 Matthew Harmsen 2015-01-23 22:47:55 UTC
Created attachment 983594 [details]
Patch to downgrade httpd 2.4 down to httpd 2.2

Re-based source tarball to 'mod_nss-1.0.10-1.fc21' in order to pick up all of the TLSv1.2 changes.

Since the 'mod_nss-1.0.10-1.fc21' source tarball was originally written    against httpd 2.4, it was necessary to construct the attached patch in order to run this code against httpd 2.2 on RHEL 6.

Comment 7 Matthew Harmsen 2015-01-23 22:49:21 UTC
Created attachment 983595 [details]
Patch to downgrade httpd 2.4 down to httpd 2.2 (spec file)

Merged spec files primarily using 'mod_nss-1.0.10-1.fc21' build logic while keeping the changelog history of 'mod_nss-1.0.8-21.el6'.

Comment 9 Namita Soman 2015-04-20 17:51:10 UTC
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 Beta (Santiago)

# rpm -qi mod_nss
Name        : mod_nss                      Relocations: (not relocatable)
Version     : 1.0.10                            Vendor: Red Hat, Inc.
Release     : 1.el6                         Build Date: Fri 23 Jan 2015 06:02:07 PM EST
Install Date: Wed 08 Apr 2015 03:34:21 PM EDT      Build Host: x86-028.build.eng.bos.redhat.com
Group       : System Environment/Daemons    Source RPM: mod_nss-1.0.10-1.el6.src.rpm
Size        : 257982                           License: ASL 2.0
Signature   : RSA/8, Wed 04 Mar 2015 07:14:43 AM EST, Key ID 938a80caf21541eb
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : https://fedorahosted.org/mod_nss/
Summary     : SSL/TLS module for the Apache HTTP server
Description :
The mod_nss module provides strong cryptography for the Apache Web
server via the Secure Sockets Layer (SSL) and Transport Layer
Security (TLS) protocols using the Network Security Services (NSS)
security library.


Using mod_nss-1.0.10-1.el6.x86_64, verified /etc/httpd/conf.d/nss.conf has:
NSSProtocol TLSv1.0,TLSv1.1,TLSv1.2
NSSProtocol TLSv1.0,TLSv1.1,TLSv1.2
NSSProtocol TLSv1.0,TLSv1.1,TLSv1.2

Comment 10 Kaleem 2015-04-24 15:46:27 UTC
Verified.

mod_nss version:
================
Installed:
  mod_nss.x86_64 0:1.0.10-1.el6  

Please find the attached snip from automation log

Comment 11 Kaleem 2015-04-24 15:48:10 UTC
Created attachment 1018532 [details]
snip from automation log

Comment 14 errata-xmlrpc 2015-07-22 06:13:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1284.html


Note You need to log in before you can comment on or make changes to this bug.