Bug 116637 - 4.1.21-2 traceback
Summary: 4.1.21-2 traceback
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-24 02:42 UTC by Gene Czarcinski
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 21:32:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2004-02-24 02:42:26 UTC
Description of problem:
After updating up2date to 4.1.21-2, I get the following traceback when
it is started:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1198, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 316, in main
    sources = sourcesConfig.getSources()
  File "sourcesConfig.py", line 169, in getSources
  File "sourcesConfig.py", line 32, in __init__
  File "sourcesConfig.py", line 61, in load
  File "sourcesConfig.py", line 128, in parseYum
NameError: global name 'up2dateUtils' is not defined

Comment 1 shrek-m 2004-02-24 11:45:49 UTC
absolutely the same message here
# cat /etc/fedora-release
Fedora Core release 1 (Yarrow)

# rpm -Fvh
/mnt/sda1/updates/download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/1/i386/up2date-*
Preparing...               
########################################### [100%]
   1:up2date                Warnung: /etc/sysconfig/rhn/sources
created as /etc/sysconfig/rhn/sources.rpmnew
########################################### [ 50%]
   2:up2date-gnome         
########################################### [100%]


"sources.rpmnew" was moved to "sources"

# rpm -qa | grep up2date
up2date-4.1.21-2
up2date-gnome-4.1.21-2

Comment 2 Bill Nottingham 2004-02-24 21:24:46 UTC
Please try 4.1.21-3, available now.

Comment 3 shrek-m 2004-02-24 22:10:24 UTC
works at least here now without problems.

$ rpm -qa up2date*
up2date-gnome-4.1.21-3
up2date-4.1.21-3


i had to
`killall rhn-applet-gui; rhn-applet-gui &`
because it was looking for a i686-directory
afterwards all was ok

$ uname -a
Linux xp1800 2.4.22-1.2174.nptl #1 Wed Feb 18 16:38:32 EST 2004 i686
athlon i386 GNU/Linux

Comment 4 Gene Czarcinski 2004-02-24 22:25:42 UTC
Sorry, available where?

Comment 5 Gene Czarcinski 2004-02-24 22:31:23 UTC
Never mind ... I was getting my FC1 and FC2 confused.

Comment 6 Alexandre Oliva 2004-02-27 21:32:18 UTC
Seems fixed to me.


Note You need to log in before you can comment on or make changes to this bug.