Bug 116641 - 'IndexError: list index out of range' python traceback from 'dir' type channel
Summary: 'IndexError: list index out of range' python traceback from 'dir' type channel
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: up2date-rhel3-u2
TreeView+ depends on / blocked
 
Reported: 2004-02-24 03:50 UTC by Mike MacCana
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 04:42:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2004-02-24 03:50:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Hey guys,

up2date dumps the following when attempting to install a package from a dir type repository.

up2date -i dnstracer

Fetching package list for channel: rhel-i386-es-3...
########################################

Fetching package list for channel: dag-dag...

Fetching http://apt.sw.be/redhat/el3/en/i386/base/pkglist.dag.bz2...
########################################

Fetching package list for channel: redhat-el3-es-packages...
########################################

Fetching package list for channel: mikes-custom-packages...
########################################

Fetching Obsoletes list for channel: rhel-i386-es-3...

Fetching Obsoletes list for channel: dag-dag...

Fetching Obsoletes list for channel: redhat-el3-es-packages...

Fetching Obsoletes list for channel: mikes-custom-packages...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
dnstracer                               1.7            1mm                 i386


Testing package set / solving RPM inter-dependencies...
########################################
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1190, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 776, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1069, in batchRun
    batch.run()
  File "up2dateBatch.py", line 79, in run
  File "up2dateBatch.py", line 147, in __getPackages
  File "up2date.py", line 182, in getPackage
  File "rpcServer.py", line 112, in doCall
  File "repoDirector.py", line 35, in getPackage
  File "rpmSource.py", line 183, in getPackage
  File "/usr/share/rhn/up2date_client/repoBackends/dirRepo.py", line 275, in getPackage
    fileName = pkg[7]
IndexError: list index out of range

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt to install a package from a dir type repository    

Actual Results:  A python traceback similar to the above, regardless of package

Additional info:

Comment 1 Adrian Likins 2004-04-06 19:32:38 UTC
seems to be fixed in 4.2.9, headed for a update release.


Note You need to log in before you can comment on or make changes to this bug.