Bug 116651 - firstboot prints obnoxious and incorrect message at boot time
firstboot prints obnoxious and incorrect message at boot time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-24 03:07 EST by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 16:13:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-02-24 03:07:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
After a kickstart install, firstboot prints on the first boot:

Firstboot has already been run once on this system.
                                                                     
          
In order to run firstboot from the command line, run the following
commands:
1) rm /etc/sysconfig/firstboot
2) /usr/sbin/firstboot
                                                                     
          
In order to run firstboot during system bootup, run the following
commands:
1) rm /etc/sysconfig/firstboot
2) chkconfig --level 5 firstboot on
3) reboot
                                                           [  OK  ]

Since this is right before rhgb completes, it's very difficult to tell
what the message says; I was worried it was some serious error message
the first few boots.  Then, when I finally managed to read it by
booting without rhgb, I realized it was a lie, since I'd never run
firstboot on that system, as it doesn't run with kickstart installs.

I understand the point of the message, but it's not a good idea to
print such a long message in every boot other than the first.  I'd
much prefer firstboot to be silent during boot.  Can it perhaps test
$2 = boot or something like that, like some network start scripts do?

Version-Release number of selected component (if applicable):
firstboot-1.3.5-1

How reproducible:
Always

Steps to Reproduce:
1.Do a kickstart install
2.Watch rhgb during the boot

Actual Results:  rhgb always switches to detail mode for me (I'm not
sure that's by design), so I always see this ugly message.

Expected Results:  I'd rather not.

Additional info:
Comment 1 Brent Fox 2004-03-08 16:13:56 EST
I've nuked the print statements since they seem like more trouble than
they are worth.  I've also modified it so that if firstboot sees that
/etc/sysconfig/firstboot exists, it will turn off it's initscript so
that all subsequent boots will not try to start it at all.

Should be fixed in firstboot-1.3.7-1.  Thanks for your report.
Comment 2 Alexandre Oliva 2004-03-18 22:56:05 EST
Confirmed, thanks!

Note You need to log in before you can comment on or make changes to this bug.