Bug 116657 - install eth0 /bin/true entry in modprobe.conf.dist causes unexpected behavior
install eth0 /bin/true entry in modprobe.conf.dist causes unexpected behavior
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: modutils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 03:45 EST by Alexandre Oliva
Modified: 2014-03-16 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.26-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 12:15:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-02-24 03:45:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
modprobe -c | grep eth0 used to print only:

alias eth0 <module>

now it prints the line above plus:

install eth0 /bin/true

This may cause problems to
/etc/sysconfig/network-scripts/network-functions:is_available(), that
runs:

    alias=`modprobe -c | awk "/^(alias|install) $1 / { print \\$3 }"`
    if [ -z "$alias" -o "$alias" = "off" -o "$alias" = "/bin/true" ]; then

it doesn't expect two lines of output, and actually fails, printing
confusing error messages because of this.

Version-Release number of selected component (if applicable):
modutils-2.4.26-5

How reproducible:
Always

Steps to Reproduce:
1.modprobe -c | grep eth0

Actual Results:  If there is an entry for eth0 in /etc/modprobe.conf,
you get two lines, one from /etc/modprobe.conf, one from
/etc/modprobe.conf.dist, the second being a dummy install /bin/true line.

Expected Results:  Just the alias line in /etc/modprobe.conf

Additional info:
Comment 1 Bill Nottingham 2004-02-24 12:15:41 EST
Fixed in 2.4.26-6.
Comment 2 Alexandre Oliva 2004-02-24 15:01:25 EST
Confirmed, thanks.

Note You need to log in before you can comment on or make changes to this bug.