Bug 116662 - firewire modules should be loaded before raidstarting and vgscanning
firewire modules should be loaded before raidstarting and vgscanning
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 04:09 EST by Alexandre Oliva
Modified: 2014-03-16 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 17:01:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-02-24 04:09:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
As firewire external disks become more common (much to your despair
:-), people might want to have their data in raid devices in external
firewire disks, in logical volumes as well.  Note I'm not talking
about the root fs on such a disk (which is what I do and requires
additional modules in sbp2), but rather about say /home or other
non-system-related filesystems.  If loading firewire modules is done
too late, you end up having to do some additional magic to get raid
devices in them to not fail to start on boot, and to start them later;
and you have to vgscan after that.  A very manual process that hotplug
might help automate, but that's something for another bug report :-)

Anyhow, one could work around this by tweaking rc.modules, but why not
go ahead and move the loading of firewire right after rc.modules anyhow?

Version-Release number of selected component (if applicable):
initscripts-7.46-1.1

How reproducible:
Always

Steps to Reproduce:
1.Create non-system-related raid devices and/or volume groups using
firewire-connected hard disks
2.Reboot

Actual Results:  Raid devices won't be brought up and vgscan won't
find physical volumes before firewire modules are loaded.

Expected Results:  It wouldn't be hard to get them to be loaded before
the last round of raid starting and vgscanning in rc.sysinit.

Additional info:
Comment 1 Alexandre Oliva 2004-04-08 17:01:20 EDT
Looks like the modprobe.conf/mkinitrd change mentioned in bug 103665
fixed this as a side effect.  Nice!

Note You need to log in before you can comment on or make changes to this bug.